Bug 1294692 - Octave installs www.octave.org-octave.desktop (instead of octave.desktop)
Octave installs www.octave.org-octave.desktop (instead of octave.desktop)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: octave (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 13:19 EST by Colin Macdonald
Modified: 2016-01-04 12:54 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 12:54:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Macdonald 2015-12-29 13:19:30 EST
Octave installs "www.octave.org-octave.appdata.xml" and "www.octave.org-octave.desktop".  Is this the intended behaviour?  If so, why?

If it is, the various octave-<pkg> will need to patch their .metainfo.xml files which need to mention the .desktop file that they extend.

(So far only octave-symbolic has a metainfo.xml file but I was planning to patch some and start a discussion upstream for the others.)
Comment 1 Orion Poplawski 2015-12-29 13:21:41 EST
(In reply to Colin Macdonald from comment #0)
> Octave installs "www.octave.org-octave.appdata.xml" and
> "www.octave.org-octave.desktop".  Is this the intended behaviour?  If so,
> why?

These are the upstream names for the files.  You should ask them.
Comment 2 Colin Macdonald 2016-01-04 12:54:01 EST
Indeed it is not Fedora-specific.

It is supposed to be like that, [at least for now](http://lists.gnu.org/archive/html/octave-maintainers/2016-01/msg00004.html)

Thanks, closing.

Note You need to log in before you can comment on or make changes to this bug.