Bug 129471 - New window appears behind old
New window appears behind old
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-09 11:30 EDT by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 00:13:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-08-09 11:30:05 EDT
Description of problem:
New terminal windows appear behind old ones, leaving no window with
focus.  Is this annoying behaviour intentional?

Version-Release number of selected component (if applicable):
2.8.2-1

How reproducible:
100%

Steps to Reproduce:
1. Start gnome-terminal from the menu.
2. Type in it (just 'x' is enough)
3. Start gnome-terminal from the menu.
  
Actual results:
The new window appears behind the old; focus is lost.

Expected results:
New window appears on top of the old, with focus.
Comment 1 Elijah Newren 2004-10-31 01:33:42 EST
It was due to an incomplete implementation of focus stealing
prevention (note that this behavior was disabled in the stable 2.8.5
and 2.8.6 releases of metacity).  See
http://bugzilla.gnome.org/show_bug.cgi?id=151245 and
http://bugzilla.gnome.org/show_bug.cgi?id=156413.

Note You need to log in before you can comment on or make changes to this bug.