Bug 1294712 - conflict between wxGTK3-devel-3.0.2-11.fc23.i686.rpm and wxGTK3-devel-3.0.2-11.fc23.x86_64
conflict between wxGTK3-devel-3.0.2-11.fc23.i686.rpm and wxGTK3-devel-3.0.2-1...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wxGTK3 (Show other bugs)
23
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jeremy Newton
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 18:03 EST by Jussi Eloranta
Modified: 2016-03-16 09:30 EDT (History)
1 user (show)

See Also:
Fixed In Version: wxGTK3-3.0.2-12.fc23 wxGTK3-3.0.2-12.fc22 wxGTK3-3.0.2-12.el7 wxGTK3-3.0.2-12.el6 wxGTK3-3.0.2-17.fc23 wxGTK3-3.0.2-15.fc22 wxGTK3-3.0.2-15.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 11:21:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jussi Eloranta 2015-12-29 18:03:11 EST
Description of problem:

Use dnf to install both x86_64 and i686 packages of wxGTK3-devel and you will get (I had the 64 bit version already installed and tried adding the 32bit):

Downloading Packages:
wxGTK3-devel-3.0.2-11.fc23.i686.rpm             884 kB/s | 1.3 MB     00:01    
--------------------------------------------------------------------------------
Total                                           571 kB/s | 1.3 MB     00:02     
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/bakefile/presets/wx3/wx_presets.pyc from install of wxGTK3-devel-3.0.2-11.fc23.i686 conflicts with file from package wxGTK3-devel-3.0.2-11.fc23.x86_64
  file /usr/share/bakefile/presets/wx3/wx_presets.pyo from install of wxGTK3-devel-3.0.2-11.fc23.i686 conflicts with file from package wxGTK3-devel-3.0.2-11.fc23.x86_64

Error Summary
-------------


Version-Release number of selected component (if applicable):

3.0.2

How reproducible:

Try installing both packages on same machine.

Steps to Reproduce:
1. dnf install wxGTK3-devel.x86_64
2. dnf install wxGTK3-devel.i686

Actual results:

Only one of the packages can be installed.

Expected results:

It should be possible to have both installed.

Additional info:
Comment 1 Jeremy Newton 2015-12-31 12:18:34 EST
Yeah those files should not be in the devel file. Thanks for the catch, I'll fix it as soon as I can.
Comment 2 Fedora Update System 2016-01-01 13:38:20 EST
wxGTK3-3.0.2-12.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9109bb0f44
Comment 3 Fedora Update System 2016-01-01 13:40:20 EST
wxGTK3-3.0.2-12.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3242cef988
Comment 4 Fedora Update System 2016-01-01 13:42:13 EST
wxGTK3-3.0.2-12.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-3bb4d903bc
Comment 5 Fedora Update System 2016-01-01 13:44:28 EST
wxGTK3-3.0.2-12.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-0ed142189f
Comment 6 Fedora Update System 2016-01-02 21:48:09 EST
wxGTK3-3.0.2-12.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-0ed142189f
Comment 7 Fedora Update System 2016-01-02 21:51:23 EST
wxGTK3-3.0.2-12.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-3bb4d903bc
Comment 8 Fedora Update System 2016-01-02 22:21:54 EST
wxGTK3-3.0.2-12.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3242cef988
Comment 9 Fedora Update System 2016-01-02 22:23:21 EST
wxGTK3-3.0.2-12.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9109bb0f44
Comment 10 Fedora Update System 2016-01-04 13:50:57 EST
wxGTK3-3.0.2-12.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2016-01-10 19:52:54 EST
wxGTK3-3.0.2-12.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Jussi Eloranta 2016-01-11 22:18:46 EST
Am I doing something wrong here?

First I run:

dnf remove wxGTK3\*

then I do:

dnf install wxGTK3\*.x86_64 wxGTK3\*.i686

Reports the following:

[SKIPPED] wxGTK3-devel-3.0.2-12.fc23.i686.rpm: Already downloaded              
(2/8): wxGTK3-gl-3.0.2-12.fc23.x86_64.rpm        20 kB/s |  36 kB     00:01    
(3/8): wxGTK3-media-3.0.2-12.fc23.x86_64.rpm     31 kB/s |  57 kB     00:01    
(4/8): wxGTK3-gl-3.0.2-12.fc23.i686.rpm          56 kB/s |  36 kB     00:00    
(5/8): wxGTK3-devel-3.0.2-12.fc23.x86_64.rpm    436 kB/s | 1.3 MB     00:03    
(6/8): wxGTK3-3.0.2-12.fc23.x86_64.rpm          977 kB/s | 5.4 MB     00:05    
(7/8): wxGTK3-media-3.0.2-12.fc23.i686.rpm       61 kB/s |  57 kB     00:00    
(8/8): wxGTK3-3.0.2-12.fc23.i686.rpm            613 kB/s | 5.4 MB     00:08    

and this still finishes up with:

The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/bakefile/presets/wx3/wx_presets.pyc conflicts between attempted installs of wxGTK3-devel-3.0.2-12.fc23.i686 and wxGTK3-devel-3.0.2-12.fc23.x86_64
  file /usr/share/bakefile/presets/wx3/wx_presets.pyo conflicts between attempted installs of wxGTK3-devel-3.0.2-12.fc23.i686 and wxGTK3-devel-3.0.2-12.fc23.x86_64


Jussi
Comment 13 Fedora Update System 2016-01-17 16:59:03 EST
wxGTK3-3.0.2-12.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2016-01-17 17:54:18 EST
wxGTK3-3.0.2-12.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Jeremy Newton 2016-01-18 09:29:50 EST
Re-opened, bodhi closed it.

This is due to a typo in the SPEC file. I'll push another update when it's fixed.
Comment 16 Fedora Update System 2016-02-22 17:09:15 EST
wxGTK3-3.0.2-14.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-a28c9b7712
Comment 17 Fedora Update System 2016-02-22 17:09:15 EST
wxGTK3-3.0.2-14.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-11f4979232
Comment 18 Fedora Update System 2016-02-22 17:09:16 EST
wxGTK3-3.0.2-14.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-a28c9b7712
Comment 19 Fedora Update System 2016-02-22 17:09:18 EST
wxGTK3-3.0.2-14.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-a28c9b7712
Comment 20 Fedora Update System 2016-02-22 17:21:42 EST
wxGTK3-3.0.2-14.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-411d4e13ac
Comment 21 Fedora Update System 2016-02-22 17:22:33 EST
wxGTK3-3.0.2-14.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f389037f2c
Comment 22 Fedora Update System 2016-02-23 16:26:36 EST
wxGTK3-3.0.2-14.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-411d4e13ac
Comment 23 Fedora Update System 2016-02-24 13:23:27 EST
wxGTK3-3.0.2-14.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-a28c9b7712
Comment 24 Fedora Update System 2016-02-24 14:19:29 EST
wxGTK3-3.0.2-14.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-11f4979232
Comment 25 Fedora Update System 2016-02-24 16:52:19 EST
wxGTK3-3.0.2-14.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f389037f2c
Comment 26 Fedora Update System 2016-02-24 23:03:33 EST
wxGTK3-3.0.2-17.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8b75629956
Comment 27 Fedora Update System 2016-02-26 15:54:02 EST
wxGTK3-3.0.2-17.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8b75629956
Comment 28 Fedora Update System 2016-02-28 09:50:11 EST
wxGTK3-3.0.2-15.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ef067d677a
Comment 29 Fedora Update System 2016-02-28 09:50:11 EST
wxGTK3-3.0.2-15.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d5ff052084
Comment 30 Fedora Update System 2016-02-28 09:50:13 EST
wxGTK3-3.0.2-15.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d5ff052084
Comment 31 Fedora Update System 2016-02-29 00:24:17 EST
wxGTK3-3.0.2-17.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 32 Fedora Update System 2016-02-29 05:54:36 EST
wxGTK3-3.0.2-15.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d5ff052084
Comment 33 Fedora Update System 2016-02-29 06:23:20 EST
wxGTK3-3.0.2-15.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ef067d677a
Comment 34 Fedora Update System 2016-03-09 11:21:01 EST
wxGTK3-3.0.2-15.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 35 Fedora Update System 2016-03-09 13:45:44 EST
wxGTK3-3.0.2-15.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 36 Fedora Update System 2016-03-09 15:11:16 EST
wxGTK3-3.0.2-15.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 37 Fedora Update System 2016-03-15 18:47:18 EDT
wxGTK3-3.0.2-15.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 38 Fedora Update System 2016-03-16 09:30:34 EDT
wxGTK3-3.0.2-14.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.