Bug 1294733 - Unable to reboot atomic host after stopping RHGS container
Unable to reboot atomic host after stopping RHGS container
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhgs-server-container (Show other bugs)
Unspecified Unspecified
unspecified Severity low
: ---
: RHGS 3.1.2
Assigned To: Mohamed Ashiq
Shruti Sampat
: ZStream
Depends On: 1294459
  Show dependency treegraph
Reported: 2015-12-29 23:18 EST by Shruti Sampat
Modified: 2017-01-03 05:50 EST (History)
6 users (show)

See Also:
Fixed In Version: RHELAH 7.2.2, rhgs-server-docker-3.1.2-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-01-03 05:50:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
screenshot (24.36 KB, image/png)
2015-12-29 23:18 EST, Shruti Sampat
no flags Details

  None (edit)
Description Shruti Sampat 2015-12-29 23:18:13 EST
Created attachment 1110437 [details]

Description of problem:

Trying to reboot an atomic host after stopping a running RHGS container has problems due to failure in unmounting /var and /usr. See screenshot attached.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Stop a running RHGS container on atomic host. Doing this is impacted by BZ#1293667 every single time, but restarting docker service seems to solve the problem.
2. Remove the stopped container using `docker rm'.
3. Reboot the atomic host.

Actual results:
The machine does not come up for a few hours and stays in the state seen in the screenshot. After a couple of hours it comes up.

Expected results:
Rebooting the machine should be smooth.
Comment 2 Humble Chirammal 2016-01-02 00:11:28 EST
I believe the reboot delay comes only when there was no 'graceful shutdown' (docker stop)  of the container and we fail to do it ( #docker stop ) when the volumes are not mounted inside the container. In short, this is a side effect of 'unsuccessful bind mount' issue which is mentioned @ bz#1293669. Can you please confirm this thought ?  If that is the case, it is almost tangent to an expected result.
Comment 6 Shruti Sampat 2016-01-27 05:22:49 EST
Issue is still reproducible with steps mentioned in comment #0. Re-assigning BZ.
Comment 9 Shruti Sampat 2016-02-17 04:37:00 EST
Verified as fixed in rhgs-server-docker-3.1.2-7 with latest RHEL 7.2 atomic host.

Note You need to log in before you can comment on or make changes to this bug.