Bug 1294744 - /usr/lib/systemd/system/lircd.service is overwritten on upgrade.
/usr/lib/systemd/system/lircd.service is overwritten on upgrade.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lirc (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Alec Leamas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-30 00:10 EST by grant petersen
Modified: 2015-12-30 05:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-30 05:10:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description grant petersen 2015-12-30 00:10:44 EST
Description of problem:
/usr/lib/systemd/system/lircd.service is overwritten on lircd-core upgrade. This causes lircd to stop working if a default lircd.service file is not appropriate for the particular system it's running on.

Version-Release number of selected component (if applicable):
lircd 0.9.3a (but the last umpty ump have all done this too)

How reproducible:
Every time lircd-core is upgraded with dnf.

Steps to Reproduce:
1. Edit /usr/lib/systemd/system/lircd.service to make lircd work.
2. Upgrade lirc-core
3. Reboot.

Actual results:
irexec fails to run. (as it can't talk to lircd)


Expected results:
irexec should run and process appropriate scripts.


Additional info:
My lircd.service file's contents:

[Unit]
Description=LIRC Infrared Signal Decoder
After=network.target

[Service]
Type=simple
ExecStart=/usr/sbin/lircd --nodaemon -H devinput -d /dev/input/by-path/pci-0000:03:00.0-event-ir

[Install]
WantedBy=multi-user.target
Comment 1 Alec Leamas 2015-12-30 05:10:20 EST
This is the intended behaviour. Users who need a custom lircd.service should not edit /lib/systemd/system/lircd.service - instead a new file /etc/systemd/system/lircd.service file should be created which overrides the /lib/systemd one. Please refer to the systemd docs e. g. http://www.freedesktop.org/software/systemd/man/systemd.unit.html
Comment 2 Alec Leamas 2015-12-30 05:42:36 EST
BTW, there is no need for you to modify lircd.service. If you use the shipped variant, you can specify things like driver and device in the /etc/lirc/lirc_options.conf file. This is the intended configuration mechanism.

Note You need to log in before you can comment on or make changes to this bug.