Bug 1294764 - virt-who can't send h/g mapping's updating after 60s when it run at vdsm/rhevm mode
virt-who can't send h/g mapping's updating after 60s when it run at vdsm/rhev...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.8
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Radek Novacek
Eko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-30 03:00 EST by Liushihui
Modified: 2016-11-30 19:35 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-14 01:08:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liushihui 2015-12-30 03:00:16 EST
Description of problem:
When virt-who run at vdsm/rhevm mode, During the first virt-who's loop interval(60s), add/delete/start/stop guest in rhevm, although virt-who get the updating at the first loop, it can't send the updating to server until the second loop(120s).

Version-Release number of selected component (if applicable):
virt-who-0.16-1.el6.noarch
subscription-manager-1.16.6-1.el6.x86_64
python-rhsm-1.16.4-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Register rhel to satellite6.1
2. Configure virt-who run at vdsm/rhevm mode, then start virt-who service
3. During the first loop, add/delete/start/stop guest in rhevm, then check virt-who's log:
# tail -f /var/log/rhsm/rhsm.log

Actual results:
Virt-who can't send the updating to server at the first loop time(60s). it will send the updating to server at the second loop(120s).

================The first loop========================
2015-12-30 02:27:35,423 [virtwho.env_cmdline DEBUG] Vdsm-1(8492):MainThread @virt.py:enqueue:331 - Report gathered, putting to queue for sending
2015-12-30 02:27:35,425 [virtwho.main DEBUG] MainProcess(8482):MainThread @virtwho.py:update_report_to_send:274 - Report for config "env/cmdline" updated

================The second loop========================
2015-12-30 02:28:34,931 [virtwho.main DEBUG] MainProcess(8482):MainThread @subscriptionmanager.py:_connect:112 - Authenticating with certificate: /etc/pki/consumer/cert.pem
2015-12-30 02:28:35,536 [virtwho.env_cmdline DEBUG] Vdsm-1(8492):MainThread @virt.py:enqueue:331 - Report gathered, putting to queue for sending
2015-12-30 02:28:36,506 [virtwho.main INFO] MainProcess(8482):MainThread @subscriptionmanager.py:sendVirtGuests:136 - Sending domain info: [
    {
        "guestId": "95524370-81bb-4726-be53-112b67206093", 
        "state": 1, 
        "attributes": {
            "active": 1, 
            "hypervisorVersion": "", 
            "virtWhoType": "vdsm", 
            "hypervisorType": "qemu"
        }
    }
]
2015-12-30 02:28:39,377 [virtwho.main INFO] MainProcess(8482):MainThread @virtwho.py:_sendGuestList:250 - virt-who guest list update successful
2015-12-30 02:28:39,378 [virtwho.main DEBUG] MainProcess(8482):MainThread @virtwho.py:send_current_report:206 - Report for config "env/cmdline" sent
2015-12-30 02:28:39,380 [virtwho.main INFO] MainProcess(8482):MainThread @virtwho.py:update_report_to_send:268 - No change in report gathered using config: "env/cmdline", report not sent.

Expected results:
As virt-who has get the h/g mapping updating at the first loop, it should send the mapping's updating to server at the first loop.

Additional info:
Comment 1 Radek Novacek 2016-02-11 05:12:21 EST
Can you please share whole virt-who configuration here? Do you have for example more virt backends configured?
Comment 2 Liushihui 2016-02-14 01:08:27 EST
This problem cannot reproduced on the latest virt-who-0.16-3.el6.noarch. Therefore, close it as WORKSFORME. Thanks.
With the latest virt-who, virt-who can monitor updating in the second loop. Please see the detail as the following:
==================The first loop=============================
2016-02-14 01:02:55,356 [virtwho.main INFO] MainProcess(7827):MainThread @subscriptionmanager.py:sendVirtGuests:147 - Sending update in guests lists for config "env/cmdline": 0 guests found
2016-02-14 01:02:55,356 [virtwho.main DEBUG] MainProcess(7827):MainThread 
@subscriptionmanager.py:sendVirtGuests:148 - Domain info: []
2016-02-14 01:02:58,456 [virtwho.main DEBUG] MainProcess(7827):MainThread @virtwho.py:send_current_report:159 - Report for config "env/cmdline" sent
==================The second loop=============================

2016-02-14 01:03:55,153 [virtwho.env_cmdline DEBUG] Vdsm-1(7835):MainThread @virt.py:enqueue:351 - Report gathered, putting to queue for sending
2016-02-14 01:03:59,459 [virtwho.main DEBUG] MainProcess(7827):MainThread @subscriptionmanager.py:_connect:121 - Authenticating with certificate: /etc/pki/consumer/cert.pem
2016-02-14 01:04:00,319 [virtwho.main INFO] MainProcess(7827):MainThread @subscriptionmanager.py:sendVirtGuests:147 - Sending update in guests lists for config "env/cmdline": 1 guests found
2016-02-14 01:04:00,319 [virtwho.main DEBUG] MainProcess(7827):MainThread @subscriptionmanager.py:sendVirtGuests:148 - Domain info: [
    {
        "guestId": "855e1a87-9d8c-48a6-b943-864d4c2f2bb9", 
        "state": 1, 
        "attributes": {
            "active": 1, 
            "hypervisorVersion": "", 
            "virtWhoType": "vdsm", 
            "hypervisorType": "qemu"
        }
    }
]
2016-02-14 01:04:02,526 [virtwho.main DEBUG] MainProcess(7827):MainThread @virtwho.py:send_current_report:159 - Report for config "env/cmdline" sent
2016-02-14 01:04:55,281 [virtwho.env_cmdline DEBUG] Vdsm-1(7835):MainThread @virt.py:enqueue:351 - Report gathered, putting to queue for sending

Note You need to log in before you can comment on or make changes to this bug.