Bug 1294773 - Host upgrade manager checks updates for all hosts at the same time
Host upgrade manager checks updates for all hosts at the same time
Status: CLOSED DUPLICATE of bug 1294772
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Oved Ourfali
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-30 04:04 EST by Moti Asayag
Modified: 2016-01-10 02:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-10 02:29:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Moti Asayag 2015-12-30 04:04:05 EST
Description of problem:
The scheduled job for checking availability of updates for the hosts is being scheduled at the same time for hosts in the system.
For RHEL/next-gen-ovirt-node hosts, it requires a dedicated thread for the duration of the ssh session. For a minutes or two there is a spike in thread consumption on the engine-server. If the repositories aren't refreshed, the check will take longer.

The purpose of the bug is to start each check in a random time, during the first hours of the engine's startup, so the overload will be divided. Future checks will be triggered based on that initial offset.

How reproducible:
always

Steps to Reproduce:
1. Have ovirt-engine with multiple hosts in up/maintenance status.
2. Start ovirt-engine, and wait for the host-upgrade-manager to check for updates.

Actual results:
The log (event-log/engine.log) indicates that all of the hosts are being examined at the same time.

Expected results:
Checking for host updates should be done more 'evenly'.
Comment 1 Moti Asayag 2016-01-10 02:29:45 EST

*** This bug has been marked as a duplicate of bug 1294772 ***

Note You need to log in before you can comment on or make changes to this bug.