Bug 1294775 - The keystone adminURL and internalURL are always created on the ctlplane
The keystone adminURL and internalURL are always created on the ctlplane
Status: CLOSED DUPLICATE of bug 1383724
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity high
: ---
: 10.0 (Newton)
Assigned To: Jiri Stransky
Shai Revivo
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-30 04:34 EST by Udi
Modified: 2017-10-02 09:08 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-14 10:56:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Udi 2015-12-30 04:34:31 EST
Description of problem:
In my ServiceNetMap I specify "KeystoneAdminApiNetwork: internal_api", but then when I run "keystone catalog" on the deployed overcloud - I see the adminURL and internalURL on the ctlplane (172.16.x.x in my case, while all other services that are mapped to internal-api are correctly on 10.35.191.x)


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.7-2.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Deploy an overcloud with network isolation, and put the KeystoneAdminApiNetwork on the internal_api network
2. Run "keystonre catalog" on the overcloud once it's deployed


Actual results:
The keystone adminURL and internalURL are always created on the ctlplane


Expected results:
The end[points should be on the network they were mapped to


Additional info:
In 7.2 this bug was fixed, but in 8.0 it is happening again.
Comment 3 Mike Burns 2016-04-07 17:03:37 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 6 Rob Crittenden 2017-02-14 10:56:11 EST

*** This bug has been marked as a duplicate of bug 1383724 ***

Note You need to log in before you can comment on or make changes to this bug.