Bug 1294794 - "Transport endpoint not connected" in heal info though hot tier bricks are up
"Transport endpoint not connected" in heal info though hot tier bricks are up
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Avra Sengupta
: Triaged, ZStream
Depends On: 1277944
Blocks: 1294797
  Show dependency treegraph
 
Reported: 2015-12-30 06:09 EST by Avra Sengupta
Modified: 2016-06-16 09:52 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1277944
: 1294797 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:52:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Avra Sengupta 2015-12-30 06:10:53 EST
Currently snapd persists the port it uses
to sign-in with glusterd, without checking 
if that particular port is being used by any 
other process. As a result, it might erroneously
sign out any other process using the same port.

Hence forcing snapd to ignore the persisted port,
and using a new one while coming up.
Comment 2 Vijay Bellur 2015-12-30 06:33:08 EST
REVIEW: http://review.gluster.org/13118 (snapd: Do not persist snapd port) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 3 Vijay Bellur 2016-01-04 00:53:28 EST
REVIEW: http://review.gluster.org/13118 (snapd: Do not persist snapd port) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 4 Vijay Bellur 2016-02-01 01:00:54 EST
REVIEW: http://review.gluster.org/13118 (snapd: Do not persist snapd port) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 5 Vijay Bellur 2016-02-01 06:02:32 EST
COMMIT: http://review.gluster.org/13118 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 4267c14e1be513b6124ef0dca75029494844f711
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Wed Dec 30 16:37:05 2015 +0530

    snapd: Do not persist snapd port
    
    Currently snapd persists the port it uses
    to sign-in with glusterd, without checking
    if that particular port is being used by any
    other process. As a result, it might erroneously
    sign out any other process using the same port.
    
    Hence forcing snapd to ignore the persisted port,
    and using a new one while coming up.
    
    Change-Id: Ibb9ec3762aac445f03d96e85660585be4ab27bcb
    BUG: 1294794
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/13118
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 6 Niels de Vos 2016-06-16 09:52:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.