Bug 1294799 - Unit test failures due to changes in python 2.7.9
Unit test failures due to changes in python 2.7.9
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-glanceclient (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 6.0 (Juno)
Assigned To: David Sariel
nlevinki
: Triaged, ZStream
Depends On:
Blocks: 1294801
  Show dependency treegraph
 
Reported: 2015-12-30 06:52 EST by Sergey Gotliv
Modified: 2016-04-26 10:21 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-glanceclient-0.14.2-4.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1294801 (view as bug list)
Environment:
Last Closed: 2016-01-03 09:35:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1404227 None None None 2015-12-30 06:52 EST

  None (edit)
Description Sergey Gotliv 2015-12-30 06:52:10 EST
Description of problem:

Glanceclient ssl tests fail on RHEL 7.2. It happens because pep-0476 which included in python 2.7.9 changes the behaviour of the SSL certificate chain handling. 

How reproducible:
100%

Steps to Reproduce:
1. Run glanceclient unittests on RHEL 7.2

Actual results:
SSL tests fail


Expected results:
All tests should pass


Additional info:
Works on RHEL 7.1
Comment 2 Sergey Gotliv 2016-01-03 09:35:31 EST
Fixed in python-glanceclient-0.14.2-4.el7ost

Note You need to log in before you can comment on or make changes to this bug.