Bug 1294873 - Do not package ghc-split on MIPS
Do not package ghc-split on MIPS
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ghc (Show other bugs)
24
mips64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: MIPS
  Show dependency treegraph
 
Reported: 2015-12-30 14:25 EST by Michal Toman
Modified: 2016-07-27 14:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: ghc-7.8.4-48.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 14:56:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
do-not-package-ghc-split-on-MIPS.patch (1.15 KB, patch)
2015-12-30 14:25 EST, Michal Toman
no flags Details | Diff

  None (edit)
Description Michal Toman 2015-12-30 14:25:24 EST
Created attachment 1110594 [details]
do-not-package-ghc-split-on-MIPS.patch

Description of problem:
We are trying to bring Fedora to MIPS platform and this requires excluding ghc-split from ghc package on MIPS.

Actual results:
ghc tries to package ghc-split that does not exist on MIPS

Expected results:
ghc does not package ghc-split on MIPS

Additional info:
Attaching a dist-git patch.
Comment 1 Jan Kurik 2016-02-24 09:11:40 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Jens Petersen 2016-03-07 11:26:18 EST
Apologies I didn't see this before...

I have committed the change to ghc.spec in pkg git master.
Comment 3 Jens Petersen 2016-05-18 21:48:08 EDT
Is that the only change in ghc.spec needed to enable MIPS?
Comment 4 Michal Toman 2016-05-20 08:00:21 EDT
Yes it is
Comment 5 Jens Petersen 2016-05-26 04:20:31 EDT
Okay thanks you for your patience.
I just pushed ghc-7.8.4-48.fc24 to koji:

http://koji.fedoraproject.org/koji/taskinfo?taskID=14258336
Comment 6 Fedora Update System 2016-05-26 21:10:41 EDT
ghc-7.8.4-48.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-adf100b036
Comment 7 Fedora Update System 2016-05-27 23:26:19 EDT
ghc-7.8.4-48.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-adf100b036
Comment 8 Jens Petersen 2016-06-03 05:23:54 EDT
Let me know if you need a F25 build too.

(F25 is moving to ghc-7.10.3 anyway.)
Comment 9 Jens Petersen 2016-06-21 20:53:54 EDT
Not sure if you are waiting for me, I am waiting for you to test this anyway, but maybe you want it to go stable before you test/build it for mips?
Comment 10 Michal Toman 2016-06-28 10:14:38 EDT
Oh, my bad, everything works fine, you may close the bug.
Comment 11 Jens Petersen 2016-07-11 02:27:38 EDT
Pardon? :)

I am but sure what you want/mean:
Are you're asking the update to be pushed stable?
Or do you mean you don't need the update anymore??

If you could update https://bodhi.fedoraproject.org/updates/FEDORA-2016-adf100b036 that would be ideal.

I am asking these questions since I only want to push trivial update for other archs if/when it is needed.
Comment 12 Fedora Update System 2016-07-27 14:56:30 EDT
ghc-7.8.4-48.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.