Bug 1294877 - kdump.conf default halt comment conflicts with man page
kdump.conf default halt comment conflicts with man page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools (Show other bugs)
7.2
Unspecified Linux
unspecified Severity low
: rc
: ---
Assigned To: Xunlei Pang
Emma Wu
:
Depends On:
Blocks: 1203710 1295826 1296180 1313485
  Show dependency treegraph
 
Reported: 2015-12-30 14:37 EST by Donald Berry
Modified: 2017-06-27 01:21 EDT (History)
4 users (show)

See Also:
Fixed In Version: kexec-tools-2.0.7-45.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:55:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald Berry 2015-12-30 14:37:35 EST
Description of problem:

/etc/kdump.conf has a comment that 'default halt' will halt the system, regardless of the success or failure of vmcore capture:
 
[root@el7a ~]# less /etc/kdump.conf
...
# default <reboot | halt | poweroff | shell | dump_to_rootfs>
...
#                         halt:   If the default action is halt, then simply
#                                 halt the system after attempting to capture
#                                 a vmcore, regardless of success or failure.

This conflicts with the kdump.conf man page, which says 'default' specifies the 'Action  to  preform in case dumping to intended target fails':

[root@el7a ~]# man kdump.conf
...
       default <reboot | halt | poweroff | shell | dump_to_rootfs>
              Action  to  preform in case dumping to intended target fails. If no default action is specified, "reboot" is assumed default.  reboot: If the default action is reboot simply reboot the system (this is what most people will want, as it returns the system to a nominal state).  shell: If the default action is shell, then  drop  to  an shell session inside the initramfs from where you can manually preform additional recovery actions.  Exiting this shell reboots the system.  halt: bring the system to a halt, requiring manual reset poweroff: The system will be powered down. dump_to_rootfs:If the default action is dump_to_rootfs, specified root will be  mounted  and dump will be saved in "path" directory.  Note: kdump uses bash as the default shell.

Version-Release number of selected component (if applicable):

[root@el7a ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.2 (Maipo)

[root@el7a ~]# rpm -q kexec-tools
kexec-tools-2.0.7-38.el7.x86_64

Additional info:

Also lots of typos in /etc/kdump.conf and man kdump.conf (e.g. 'preform', 'an shell')
Comment 9 errata-xmlrpc 2016-11-04 02:55:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2466.html

Note You need to log in before you can comment on or make changes to this bug.