Bug 1294909 - after a few successful appliance connections to VMDB, subsequent attempts to add additional appliances timeout
after a few successful appliance connections to VMDB, subsequent attempts to ...
Status: CLOSED DUPLICATE of bug 1294907
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: -- Unknown (Show other bugs)
5.5.0
All Linux
unspecified Severity high
: GA
: 5.6.0
Assigned To: John Hardy
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-30 17:06 EST by Thomas Hennessy
Modified: 2016-02-13 14:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-09 11:44:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Hennessy 2015-12-30 17:06:44 EST
Description of problem: long running sequence of sql queries initiated when a new appliance tries to insert itself into the VMDB timesout and the appliance is not associated with VMDB.


Version-Release number of selected component (if applicable):5.5.0.13


How reproducible: UNCERTAIN


Steps to Reproduce:
1.
2.
3.

Actual results: multiple attempts to add a fourth appliance into an existing VMDB complex all fail with timeouts trying to add the new appliance into the VMDB.


Expected results: new appliance should be added into existing complex


Additional info:
a long running set of queries about various tables and relations are running longer than 5 minutes and evoke a timeout from the evm.log file.  Customer modified to sql configuration file to capture all sql queries which are included in the attached set of logs. 

A few items of note:
- Region # = 80.  References to record ids that follow will assume that key prefix.
- first appliance is added with a key of '1'
- second appliance is added with a key of '2'
- third appliance added days after initial migration of database is added with a key of '634'
- the above gap in keys suggest that there is some kind of updating of the sequence field associated with the miq_servers table that may shed some light on what is happening.

- two key log sets from two appliances are provided: one from database owing appliance including postgresql.log referenced above and one from the appliance attempting to insert itself into the VMDB and timeout out.

- a copy of the database has been requested.
Comment 2 Dave Johnson 2016-02-09 11:44:10 EST

*** This bug has been marked as a duplicate of bug 1294907 ***

Note You need to log in before you can comment on or make changes to this bug.