Bug 1294910 - vdsm-python overwrites multipath.conf without find_multipaths=yes as default value
vdsm-python overwrites multipath.conf without find_multipaths=yes as default ...
Status: CLOSED NOTABUG
Product: vdsm
Classification: oVirt
Component: Tools (Show other bugs)
4.17.10
x86_64 Linux
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Yaniv Bronhaim
Aharon Canan
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-30 17:43 EST by Charlie Inglese
Modified: 2016-02-10 15:05 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1173290
Environment:
Last Closed: 2016-01-04 06:20:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
vdsm/tool/configurators/multipath.py (5.48 KB, text/plain)
2015-12-30 17:43 EST, Charlie Inglese
no flags Details

  None (edit)
Description Charlie Inglese 2015-12-30 17:43:33 EST
Created attachment 1110656 [details]
vdsm/tool/configurators/multipath.py

Add "find_multipaths yes" to the default multipath.conf
+++ This bug was initially created as a clone of Bug #1173290 +++

Description of problem:
find_multipaths default is set to no in ../vdsm/tool/configurators/multipath.py. This creates a condition where all devices are attempted to be multipathed and creates error conditions and error messages to the console, as referenced in Bug #1182048.

Please also refer to Bug #1173290

Test version:
vdsm-python-4.17.10.1-0.el7.centos.noarch

Test steps:
1. Installed vdsm
2. Reference /etc/multipath.conf file

Actual result:
/etc/multipath.conf does not have "find_multipaths yes" in the defaults section.

Expected result:
/etc/multipath.conf has "find_multipaths yes" in the defaults section.
Comment 1 Charlie Inglese 2015-12-30 17:46:18 EST
Suggest adding "find_multipaths yes" above Line 43 in the ../vdsm/tool/configurators/multipath.py
Comment 2 Fabian Deutsch 2016-01-04 06:20:57 EST
"find_multipaths yes" is functionaliyt wise not needed anymore in RHEV-H's multipath.conf, because vdsm changes the multipath configuration to multipath any device, regardless of the number of paths.

Getting rid of the error message is another issue which is currently under investigation in bug 1182048.

Thus I'm closing this bug, please reopen if you think this is necessary.

Note You need to log in before you can comment on or make changes to this bug.