Bug 1294947 - k3b does not work with cdrskin
k3b does not work with cdrskin
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libburn (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
: Patch, Triaged
: 1303374 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-31 02:55 EST by Knut J BJuland
Modified: 2016-02-08 04:21 EST (History)
12 users (show)

See Also:
Fixed In Version: libburn-1.4.2-2.fc23 libburn-1.4.2-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-31 04:20:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error message when using cdrskin as cdrecord in k3b (87.29 KB, image/png)
2015-12-31 02:55 EST, Knut J BJuland
no flags Details

  None (edit)
Description Knut J BJuland 2015-12-31 02:55:53 EST
Created attachment 1110704 [details]
error message when using cdrskin as cdrecord in k3b

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. set a link to cdrecord to cdrskin
2. burn a dvd for instant Fedora 23 DVD
3.

Actual results:
It failed with error message that I attach as png file

Expected results:
it should burn

Additional info:
I have used alternative system to set cdrskin as cdrecord as K3B will not find cdrskin otherwise.
Comment 1 Knut J BJuland 2015-12-31 03:07:34 EST
Devices
-----------------------
Optiarc DVD RW AD-5260S 1.00 (/dev/sr0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Layer Jump] [%7]
TSSTcorp BDDVDW SE-506BB TS00 (/dev/sr1, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, BD-ROM, BD-R, BD-RE, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW, BD-ROM, BD-R Sequential (SRM), BD-R Random (RRM), BD-RE] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Layer Jump, Random Recording, Sequential Recording, Sequential Recording + POW] [%7]

System
-----------------------
K3b Version: 2.0.3
KDE Version: 4.14.14
QT Version:  4.8.7
Kernel:      4.2.8-300.fc23.x86_64

Used versions
-----------------------
cdrecord: 2.1a27

cdrecord
-----------------------
cdrskin 1.4.2 : limited cdrecord compatibility wrapper for libburn
cdrskin: verbosity level : 1
cdrskin: NOTE : greying out all drives besides given dev='/dev/sr0'
cdrskin: scanning for devices ...
cdrskin: ... scanning for devices done
Note: This is not cdrecord by Joerg Schilling. Do not bother him.
      See cdrskin start message on stdout. See --help. See -version.
cdrskin: FATAL : failed to attach fifo.

cdrecord command:
-----------------------
/usr/bin/cdrecord -v dev=/dev/sr0 speed=18 -sao driveropts=burnfree -data -tsize=2114048s -
Comment 2 Knut J BJuland 2015-12-31 03:10:24 EST
However when I use cdrskin from command line it works with the same command. cdrskin -v dev=/dev/sr0 --speed=18 -sao driveropts=burnfree -data -tsize=2114048s CentOS-7-x86_64-DVD-1511.iso 
cdrskin 1.4.2 : limited cdrecord compatibility wrapper for libburn
cdrskin: verbosity level : 1
cdrskin: NOTE : greying out all drives besides given dev='/dev/sr0'
cdrskin: scanning for devices ...
cdrskin: ... scanning for devices done
cdrskin: beginning to burn disc
cdrskin: status 1 burn_disc_blank "The drive holds a blank disc"
Current: DVD-R sequential recording
Track 01: data  4129 MB        
Total size:     4129 MB (469:49.30) = 2114048 sectors
Lout start:     4129 MB (469:51/30) = 2114198 sectors
Starting to write CD/DVD at speed 18 in real SAO mode for single session.
Last chance to quit, starting real write in   0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
Starting new track at sector: 0
Comment 3 Thomas Schmitt 2016-01-28 05:47:22 EST
Hi,

this is an upstream bug that was introduced in cdrskin-1.4.2, i fear.

I discovered it only yesterday and now uploaded a new development
snapshot

  http://scdbackup.sourceforge.net/cdrskin-1.4.3.tar.gz

Now i stumble over this month-old bug report. (I wonder why Google
did not show it to me on January 1.)

The fix is in
  http://libburnia-project.org/changeset/5653/libburn/trunk/cdrskin/cdrskin.c

My candidate for a Debian patch is this:
-----------------------------------------------------------------
Description: Bug fix: cdrskin failed with "failed to attach fifo"
when burning from stdin. Regression of 1.4.2, rev 5522.
Applied-Upstream: 1.4.4, http://libburnia-project.org/changeset/5653
Author: Thomas Schmitt <scdbackup@gmx.net>

--- a/cdrskin/cdrskin.c
+++ b/cdrskin/cdrskin.c
@@ -1446,7 +1446,7 @@
      track->fixed_size= Cdrtrack_minimum_sizE*track->sector_size;
    }
  }
- return((*fd >= 0) * (2 * self_opened));
+ return((*fd >= 0) * (1 + self_opened));
 }
-----------------------------------------------------------------

Sorry for the inconvenience.

Have a nice day :)

Thomas
Comment 4 Rex Dieter 2016-01-28 06:43:34 EST
Triaging to libburn (owner of cdrskin)
Comment 5 Thomas Schmitt 2016-01-30 05:18:10 EST
Hi,

i meanwhile made a bug fix release of libburn-1.4.2

  http://files.libburnia-project.org/releases/libburn-1.4.2.pl01.tar.gz

Have a nice day :)

Thomas
Comment 6 Fedora Update System 2016-01-30 13:14:51 EST
libburn-1.4.2-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1f3ed3545a
Comment 7 Fedora Update System 2016-01-30 13:15:31 EST
libburn-1.4.2-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-88cffb5278
Comment 8 Fedora Update System 2016-01-30 13:16:09 EST
libburn-1.4.2-2.el5 has been submitted as an update to Fedora EPEL 5. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-ebbe8b6924
Comment 9 Fedora Update System 2016-01-31 01:18:48 EST
libburn-1.4.2-2.el5 has been pushed to the Fedora EPEL 5 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-ebbe8b6924
Comment 10 Fedora Update System 2016-01-31 01:49:35 EST
libburn-1.4.2-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1f3ed3545a
Comment 11 Fedora Update System 2016-01-31 03:24:40 EST
libburn-1.4.2-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-88cffb5278
Comment 12 Knut J BJuland 2016-01-31 04:20:50 EST
Please mark this a fixed. I have burned a dvd in k3b using cdrskin at it worked with cdrskin 1.4.2-2.
Comment 13 Robert Scheck 2016-01-31 08:40:33 EST
*** Bug 1303374 has been marked as a duplicate of this bug. ***
Comment 14 Robert Scheck 2016-01-31 08:48:04 EST
Knut, manually closing this bug report does not really help - because it is
referenced with Bodhi. Thus Bodhi will likely re-open this bug report until
one of the updates reaches the stable repository. It however would be very
helpful if you could visit one of the Bodhi URLs above (actually the package
you tested) and add positive rating (= karma) there.
Comment 15 Fedora Update System 2016-02-02 00:49:16 EST
libburn-1.4.2-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2016-02-08 04:21:41 EST
libburn-1.4.2-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.