Bug 1294954 - tier-snapshot.t runs too slowly on RHEL6
tier-snapshot.t runs too slowly on RHEL6
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
:
Depends On: 1293523
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-31 04:28 EST by Ravishankar N
Modified: 2016-04-19 03:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1293523
Environment:
Last Closed: 2016-04-19 03:52:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2015-12-31 04:28:51 EST
+++ This bug was initially created as a clone of Bug #1293523 +++

Description of problem:

On RHEL6, we access CTR from the tier daemon using an IPC call. This is slow. It results in pause timeout when trying to create a snapshot.

Version-Release number of selected component (if applicable):


How reproducible:

Run tier-snapshot.t test, you will see a failure.

Steps to Reproduce:
1.
2.
3.

Actual results:

Fail test 12

Expected results:

Pass all

Additional info:

A fix could be to set the timeout larger on RHEL6.

--- Additional comment from Vijay Bellur on 2015-12-21 22:21:30 EST ---

REVIEW: http://review.gluster.org/13056 (tier/snap : Adding tier-snapshot.t to bad test) posted (#1) for review on master by Joseph Fernandes

--- Additional comment from Vijay Bellur on 2015-12-21 22:23:08 EST ---

REVIEW: http://review.gluster.org/13056 (tier/snap : Adding tier-snapshot.t to bad test) posted (#2) for review on master by Joseph Fernandes

--- Additional comment from Vijay Bellur on 2015-12-21 23:59:20 EST ---

COMMIT: http://review.gluster.org/13056 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit aa017dc1527c30fedb4b76cfb6c7601b2ec20c43
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Tue Dec 22 08:50:26 2015 +0530

    tier/snap : Adding tier-snapshot.t to bad test
    
    ./tests/basic/tier/tier-snapshot.t to bad test
    
     On RHEL6 the pause tier mechanism times out due to slow IPC calls
     between the tier daemon and brick process. A workaround may be to
     increase the timeout or improve the speed of RHEL6
    
    Change-Id: I5af6123923416e611672ffe2aaea3f0dd7964dd9
    BUG: 1293523
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/13056
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 1 Vijay Bellur 2015-12-31 04:35:07 EST
REVIEW: http://review.gluster.org/13126 (tests: add tests/basic/tier/tier-snapshot.t to bad tests) posted (#1) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)
Comment 2 Vijay Bellur 2016-01-02 01:28:12 EST
COMMIT: http://review.gluster.org/13126 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit 78cd19946cd255e1dc483f19f49c4961902292d8
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Thu Dec 31 15:00:26 2015 +0530

    tests: add tests/basic/tier/tier-snapshot.t to bad tests
    
    Seems to fail a lot on the 3.7 branch as well:
    https://build.gluster.org/job/rackspace-regression-2GB-triggered/17231/consoleFull
    https://build.gluster.org/job/rackspace-regression-2GB-triggered/17232/consoleFull
    https://build.gluster.org/job/rackspace-regression-2GB-triggered/17210/consoleFull
    
    Since the test is anyway added to bad tests in master
    (http://review.gluster.org/#/c/13056/), add it in 3.7 too.
    
    Change-Id: I93dabb445e7043315df0d1150fe0895c2282a45d
    BUG: 1294954
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/13126
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Kaushal 2016-04-19 03:52:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.