This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1294956 - set-label returns wrong error message when set the ext3/ext4 filesystem label
set-label returns wrong error message when set the ext3/ext4 filesystem label
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs (Show other bugs)
6.8
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Pino Toscano
Virtualization Bugs
:
Depends On:
Blocks: 1301844
  Show dependency treegraph
 
Reported: 2015-12-31 04:35 EST by Hu Zhang
Modified: 2016-05-10 15:56 EDT (History)
5 users (show)

See Also:
Fixed In Version: libguestfs-1.20.11-17.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 15:56:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hu Zhang 2015-12-31 04:35:33 EST
Description of problem:
set-label returns wrong worning message when set the ext3/ext4 filesystem label. Same result on rhel7.2

Version-Release number of selected component (if applicable):
libguestfs-1.20.11-16.el6.x86_64
libguestfs-winsupport-1.0-7.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. # guestfish -a test.raw
><fs> list-filesystems
/dev/sda1: ext3

2. Set the label as "AAAAAAAAAAAAAAAAAA"
><fs> set-label /dev/sda1 "AAAAAAAAAAAAAAAAAA"
libguestfs: error: set_label: AAAAAAAAAAAAAAAAAA: ext2 labels are limited to 16 bytes

3.
><fs> mkfs ext4 /dev/sda1
><fs> set-label /dev/sda1 "AAAAAAAAAAAAAAAAAA"
libguestfs: error: set_label: AAAAAAAAAAAAAAAAAA: ext2 labels are limited to 16 bytes


Actual results:
In step 2, the filesystem format, ext2 in the error message is different from the the actual filesystem format.

Expected results:
In step 2, the error message should be "libguestfs: error: set_label: AAAAAAAAAAAAAAAAAA: ext3 labels are limited to 16 bytes".
In step 3, the error message should be "libguestfs: error: set_label: AAAAAAAAAAAAAAAAAA: ext4 labels are limited to 16 bytes".


Additional info:
Comment 5 errata-xmlrpc 2016-05-10 15:56:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0762.html

Note You need to log in before you can comment on or make changes to this bug.