Bug 1294963 - [ESR45] firefox crashing due to plugin-container segfault
[ESR45] firefox crashing due to plugin-container segfault
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firefox (Show other bugs)
7.1
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Martin Stransky
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-31 05:25 EST by Deepu K S
Modified: 2016-05-12 06:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 06:31:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[abrt] firefox-38.4.0-1.el7_1: plugin-container killed by SIGSEGV (7.77 MB, application/x-tar)
2015-12-31 06:29 EST, Deepu K S
no flags Details
Installed RPMS on system (2.16 MB, text/plain)
2015-12-31 06:32 EST, Deepu K S
no flags Details
[abrt] firefox-38.3.0-2.el7_1: plugin-container killed by SIGSEGV (1.76 MB, application/x-tar)
2015-12-31 06:35 EST, Deepu K S
no flags Details

  None (edit)
Description Deepu K S 2015-12-31 05:25:32 EST
Description of problem:

[abrt] firefox-38.4.0-1.el7_1: plugin-container killed by SIGSEGV

Firefox is crashing due to segfault in plugin-container. This has happened once with java plugin (libnpjp2.so) as well as flash plugin (libflashplayer.so) 

Core was generated by `/usr/lib64/firefox/plugin-container /usr/lib64/flash-plugin/libflashplayer.so -'.
Program terminated with signal 11, Segmentation fault.
#0  mozalloc_abort (
    msg=msg@entry=0x7f84b713048c "[NPAPI 426] ###!!! ABORT: Aborting on channel error.: file /builddir/build/BUILD/firefox-38.3.0/mozilla-esr38/ipc/glue/MessageChannel.cpp, line 1584") at /usr/src/debug/firefox-38.3.0/mozilla-esr38/memory/mozalloc/mozalloc_abort.cpp:37
37	    MOZ_CRASH();


Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 7.1
firefox-38.4.0-1.el7_1.x86_64

How reproducible:
Mostly.

Steps to Reproduce:
No exact reproducer. It happens when accessing some websites, mostly when plugins are in use.

Actual results:
plugin-container segfault.

Expected results:
plugin-container shouldn't crash.

Additional info:
Comment 2 Deepu K S 2015-12-31 06:29 EST
Created attachment 1110741 [details]
[abrt] firefox-38.4.0-1.el7_1: plugin-container killed by SIGSEGV

cmdline:        /usr/lib64/firefox/plugin-container /usr/lib/jvm/java-1.7.0-oracle-1.7.0.91-1jpp.1.el7_1.x86_64/jre/lib/amd64/libnpjp2.so -greomni /usr/lib64/firefox/omni.ja -appomni /usr/lib64/firefox/browser/omni.ja -appdir /usr/lib64/firefox/browser 30320 plugin

# md5sum coredump 
6a3742499be04552a0f64a835f3ae2db  coredump
Comment 3 Deepu K S 2015-12-31 06:32 EST
Created attachment 1110742 [details]
Installed RPMS on system
Comment 4 Deepu K S 2015-12-31 06:35 EST
Created attachment 1110743 [details]
[abrt] firefox-38.3.0-2.el7_1: plugin-container killed by SIGSEGV

cmdline:        /usr/lib64/firefox/plugin-container /usr/lib64/flash-plugin/libflashplayer.so -greomni /usr/lib64/firefox/omni.ja -appomni /usr/lib64/firefox/browser/omni.ja -appdir /usr/lib64/firefox/browser 16054 plugin

# md5sum coredump 
314796f376c3e7b059822496d387e2ad  coredump
Comment 6 Martin Stransky 2016-02-26 09:33:47 EST
That should be fixed by update to ESR45 which contains a fix for that. Let's wait until ESR45 is out and then retest.
Comment 12 Martin Stransky 2016-05-12 06:31:00 EDT
should be fixed now - please reopen if not.

Note You need to log in before you can comment on or make changes to this bug.