Bug 1294984 - [RFE][TEXT] - add warning when running log collector without filters.
[RFE][TEXT] - add warning when running log collector without filters.
Status: CLOSED CURRENTRELEASE
Product: ovirt-log-collector
Classification: oVirt
Component: RFEs (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Rafael Martins
Petr Kubica
: EasyFix, FutureFeature, Improvement
Depends On: 1351988
Blocks: 971853
  Show dependency treegraph
 
Reported: 2015-12-31 07:53 EST by Yaniv Lavi
Modified: 2016-08-15 21:03 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, if ovirt-log-collector was called without filters in large scale environments hours of logs were collected and the output was large. Now, ovirt-log-collector shows a warning if called without any filters.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-01 08:27:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
grafuls: testing_plan_complete-
ylavi: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 55668 master NEW engine-log-collector: warn users if collecting logs from all hosts 2016-04-04 11:47 EDT

  None (edit)
Description Yaniv Lavi 2015-12-31 07:53:13 EST
Description of problem:
Log collector doesn't require any filters. In a scale environment this can mean hours of log collection and big output size. We should warn the user when doing this.
Comment 1 Sandro Bonazzola 2016-05-02 06:01:46 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 2 Petr Kubica 2016-07-26 02:42:52 EDT
Verified in ovirt-log-collector-4.0.0-1.el7ev.noarch

# ovirt-log-collector 
This command will collect system configuration and diagnostic
information from this system.
The generated archive may contain data considered sensitive and its
content should be reviewed by the originating organization before
being passed to any third party.
No changes will be made to system configuration.
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to skip): 
WARNING: This ovirt-log-collector call will collect logs from all available hosts. This may take long time, depending on the size of your deployment
INFO: Gathering oVirt Engine information...
INFO: Gathering PostgreSQL the oVirt Engine database and log files from localhost...
About to collect information from 2 hypervisors. Continue? (Y/n): y
INFO: Gathering information from selected hypervisors...

Note You need to log in before you can comment on or make changes to this bug.