Bug 1294985 - [abrt] kate: QXcbWindow::setParent(): kate killed by SIGSEGV
[abrt] kate: QXcbWindow::setParent(): kate killed by SIGSEGV
Status: CLOSED DUPLICATE of bug 1291003
Product: Fedora
Classification: Fedora
Component: kate (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:515ab67efd96322d74785078807...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-31 08:02 EST by Kirys
Modified: 2016-01-05 14:51 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-01 23:30:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (38.98 KB, text/plain)
2015-12-31 08:02 EST, Kirys
no flags Details
File: cgroup (190 bytes, text/plain)
2015-12-31 08:02 EST, Kirys
no flags Details
File: core_backtrace (14.76 KB, text/plain)
2015-12-31 08:02 EST, Kirys
no flags Details
File: dso_list (17.03 KB, text/plain)
2015-12-31 08:02 EST, Kirys
no flags Details
File: environ (3.67 KB, text/plain)
2015-12-31 08:03 EST, Kirys
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-31 08:03 EST, Kirys
no flags Details
File: maps (82.65 KB, text/plain)
2015-12-31 08:03 EST, Kirys
no flags Details
File: mountinfo (3.40 KB, text/plain)
2015-12-31 08:03 EST, Kirys
no flags Details
File: namespaces (85 bytes, text/plain)
2015-12-31 08:03 EST, Kirys
no flags Details
File: open_fds (1.50 KB, text/plain)
2015-12-31 08:03 EST, Kirys
no flags Details
File: proc_pid_status (1008 bytes, text/plain)
2015-12-31 08:03 EST, Kirys
no flags Details
File: var_log_messages (700 bytes, text/plain)
2015-12-31 08:03 EST, Kirys
no flags Details

  None (edit)
Description Kirys 2015-12-31 08:02:45 EST
Description of problem:
Just clicked file/open after a fresh start and instead of showing the open dialog window kate closes with sigfault.
It happens 94% of the times.
I have a system with 3 monitors and i use the kde spin of fedora

Version-Release number of selected component:
kate-15.04.3-1.fc22

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        kate
crash_function: QXcbWindow::setParent
executable:     /usr/bin/kate
global_pid:     2192
kernel:         4.2.8-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 QXcbWindow::setParent at qxcbwindow.cpp:1499
 #1 QWindow::setParent at kernel/qwindow.cpp:614
 #2 QWidgetPrivate::setParent_sys at kernel/qwidget.cpp:10543
 #3 QWidget::setParent at kernel/qwidget.cpp:10398
 #5 QDialogButtonBox::addButton at widgets/qdialogbuttonbox.cpp:761
 #6 KDEPlatformFileDialog::KDEPlatformFileDialog at ../../../src/platformtheme/kdeplatformfiledialoghelper.cpp:103
 #7 KDEPlatformFileDialogHelper::KDEPlatformFileDialogHelper at ../../../src/platformtheme/kdeplatformfiledialoghelper.cpp:201
 #8 KdePlatformTheme::createPlatformDialogHelper at ../../../src/platformtheme/kdeplatformtheme.cpp:269
 #9 QDialogPrivate::platformHelper at dialogs/qdialog.cpp:94
 #10 platformFileDialogHelper at dialogs/qfiledialog_p.h:112

Potential duplicate: bug 1290988
Comment 1 Kirys 2015-12-31 08:02:52 EST
Created attachment 1110770 [details]
File: backtrace
Comment 2 Kirys 2015-12-31 08:02:54 EST
Created attachment 1110771 [details]
File: cgroup
Comment 3 Kirys 2015-12-31 08:02:56 EST
Created attachment 1110772 [details]
File: core_backtrace
Comment 4 Kirys 2015-12-31 08:02:58 EST
Created attachment 1110773 [details]
File: dso_list
Comment 5 Kirys 2015-12-31 08:03:00 EST
Created attachment 1110774 [details]
File: environ
Comment 6 Kirys 2015-12-31 08:03:02 EST
Created attachment 1110775 [details]
File: limits
Comment 7 Kirys 2015-12-31 08:03:05 EST
Created attachment 1110776 [details]
File: maps
Comment 8 Kirys 2015-12-31 08:03:07 EST
Created attachment 1110777 [details]
File: mountinfo
Comment 9 Kirys 2015-12-31 08:03:08 EST
Created attachment 1110778 [details]
File: namespaces
Comment 10 Kirys 2015-12-31 08:03:10 EST
Created attachment 1110779 [details]
File: open_fds
Comment 11 Kirys 2015-12-31 08:03:12 EST
Created attachment 1110780 [details]
File: proc_pid_status
Comment 12 Kirys 2015-12-31 08:03:14 EST
Created attachment 1110781 [details]
File: var_log_messages
Comment 13 Rex Dieter 2016-01-01 23:30:23 EST

*** This bug has been marked as a duplicate of bug 1291003 ***

Note You need to log in before you can comment on or make changes to this bug.