Bug 1295001 - kickstart fails - xfs invalid default fs type
kickstart fails - xfs invalid default fs type
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-31 13:03 EST by Paul Armstrong
Modified: 2016-01-05 14:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-05 14:55:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of installer error (121.69 KB, image/png)
2015-12-31 13:03 EST, Paul Armstrong
no flags Details
treeinfo file from kickstart tree (2.00 KB, text/plain)
2015-12-31 13:09 EST, Paul Armstrong
no flags Details

  None (edit)
Description Paul Armstrong 2015-12-31 13:03:30 EST
Created attachment 1110789 [details]
Screen shot of installer error

Description of problem:
Provisioning from Satellite 6.1.5 to RHEV 3.4 specifying 7.2 kickstart media 
(treeinfo attached)

using any partition table


install fails when creating volumes 
"Value Error: new value nonexistent xfs filesystem is not valid as default fs type"
self._check_valid_fstype(newtype)
File "/usr/lib/python2.7/site-packages/blivet/__init__.py"

Version-Release number of selected component (if applicable):


How reproducible:
always - even deleted all my Satellite content and re-installed
Deployment works fine with 7.1 kickstart image

Steps to Reproduce:
1. create a partition table in Satellite e.g.
zerombr
clearpart --all --initlabel
autopart

2. create a new host and select 7.2 kickstart media
3. submit the creation

Actual results:

"Value Error: new value nonexistent xfs filesystem is not valid as default fs type"
self._check_valid_fstype(newtype)
File "/usr/lib/python2.7/site-packages/blivet/__init__.py"


Expected results:
installation proceeds normally

Additional info:

Attached screenshot
Attached treeinfo from kickstart
Comment 2 Paul Armstrong 2015-12-31 13:09 EST
Created attachment 1110802 [details]
treeinfo file from kickstart tree
Comment 3 David Lehman 2016-01-04 16:18:59 EST
FWIW the image you attached is not an installer error message.

Something in the media is missing that is needed to support XFS. That probably means either that your kernel does not match the media (it must) or you have custom media that has issues (eg: missing xfs utilities).
Comment 4 Paul Armstrong 2016-01-04 16:35:21 EST
Thanks David, didn't know where to put this one... Kickstart image, so figured it might land here. Rebuilt my Satellite Server and content. Still happens. Who do we ping on this one?
Comment 5 Brian Lane 2016-01-04 20:35:56 EST
This error usually indicates that you have a mismatch between the kernel you are using and the initrd and/or stage2 image. You have to make sure that they are all from the same installer media. You can't mix, say, a RHEL 7.1 kernel with the initrd/stage2 from rhel7.2
Comment 6 Paul Armstrong 2016-01-05 14:39:27 EST
OK. Well. I guess I need to move this over to the Satellite team or the CDN team as the content is not coming down to the Satellite properly. I am not building the kickstart images nor configuring their component locations. I am simply synching up the content to my Satellite and deploying systems. It results in the aforementioned error.
Comment 7 Paul Armstrong 2016-01-05 14:55:13 EST
marking closed not a bug

Note You need to log in before you can comment on or make changes to this bug.