Bug 1295031 - cannot preview files under wayland/XWayland
Summary: cannot preview files under wayland/XWayland
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sushi
Version: 23
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Elad Alfassa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2016-01-01 04:47 UTC by smitna
Modified: 2016-09-27 07:13 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 07:13:08 UTC


Attachments (Terms of Use)
simple wrapper for command line usage (237 bytes, application/x-shellscript)
2016-01-01 04:47 UTC, smitna
no flags Details

Description smitna 2016-01-01 04:47:36 UTC
Created attachment 1110884 [details]
simple wrapper for command line usage

Description of problem:
See Summary.


Version-Release number of selected component (if applicable):
Name        : sushi
Version     : 3.18.0
Release     : 1.fc23
Architecture: x86_64


Steps to Reproduce:

1)  Start sushi from any one of the following sessions (see attachment for sushi.sh):

1.1)  GNOME/Wayland session:  select a preview compatible file in Nautilus and press spacebar
1.2)  GNOME/Wayland session; invoke as follows:
$ env GDK_BACKEND=x11 sushi.sh /usr/share/fedora-logos/fedora_logo.svg
1.3)  Weston session; invoke from weston-terminal as follows:
$ dbus-run-session -- env GDK_BACKEND=wayland sushi.sh /usr/share/fedora-logos/fedora_logo.svg
1.4)  Weston session with xwayland.so module enabled; invoke from weston-terminal as follows:
$ dbus-run-session -- env GDK_BACKEND=x11 sushi.sh /usr/share/fedora-logos/fedora_logo.svg


Actual results:
Abnormal termination.

GNOME/Wayland (1.1, 1.2):  ABRT triggered but remotely generated backtrace is unusable:
< https://retrace.fedoraproject.org/faf/reports/952477/ >
Not enough free disk space to generate backtrace locally.

GNOME/Wayland (1.2 only):  terminal output as follows:
Error: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
(According to introspection data, you need to pass 'sib')

Weston (1.3, 1.4):  terminal output as follows:
Activating service name='org.gnome.NautilusPreviewer'
Activating service name='org.a11y.Bus'
Successfully activated service 'org.a11y.Bus'
Activating service name='org.gtk.vfs.Daemon'
Successfully activated service 'org.gtk.vfs.Daemon'
Successfully activated service 'org.gnome.NautilusPreviewer'
Error: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
(According to introspection data, you need to pass 'sib')


Additional info:
Works fine under GNOME/X11.

Comment 1 Kamil Páral 2016-01-04 09:54:50 UTC
I can confirm this, sushi crashes under GNOME+Wayland. ABRT fails to generate a backtrace, it claims it is "unusable".

Comment 2 mlainz@gmail.com 2016-08-24 12:06:56 UTC
I have the same bug on Fedora 24 + Wayland (shushi does work with X11).

Comment 3 Elad Alfassa 2016-08-25 18:21:25 UTC
There are two upstream bugs open for this:
https://bugzilla.gnome.org/show_bug.cgi?id=766750
https://bugzilla.gnome.org/show_bug.cgi?id=766750

Since it doesn't look like sushi is getting much attention upstream, I don't think it will grow Wayland support in time for Fedora 25 (in which Wayland is going to be the default).

Therefor, we have two options of handling this going forward - and they are not mutually exclusive:
1) We can patch sushi's startup script to make it use XWayland. While this is suboptimal, it will probably mean sushi will keep working, but I haven't tested that yet.

2) We can remove sushi from the default installation, since it's clearly not getting much attention upstream.

Regardless of what the Workstation WG decides to do, I think this should be a Fedora 25 Final blocker bug, according to the following criteria: https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria#Default_application_functionality

Comment 4 Elad Alfassa 2016-08-25 18:22:07 UTC
Sorry, I accidentally linked to the same upstream bug twice. Here's the second one:

https://bugzilla.gnome.org/show_bug.cgi?id=712618

Comment 5 Fedora Blocker Bugs Application 2016-08-25 18:24:13 UTC
Proposed as a Blocker for 25-final by Fedora user elad using the blocker tracking app because:

 https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria#Default_application_functionality

sushi is arguably a "default application" or at least a part of it, and it will not function properly on Fedora 25 if Fedora 25 defaults to Wayland.

Comment 6 Elad Alfassa 2016-08-25 20:57:53 UTC
I should have tested this before making noise about it. It seems to be working correctly for me on Wayland with fully-up-to-date Fedora 24.

Removing blocker proposal and closing. If you think I'm mistaken please feel free to reopen the bug or comment here asking me to reopen it.

The only crash I *am* seeing with sushi on Wayland right now is gstreamer related, and only happens for video files when gstreamer1-vaapi is installed. Since totem crashes the same way, this is not a sushi bug but rather a gstreamer1-vaapi bug.

What kind of file types have you been trying to preview that triggered this crash?

Comment 7 Elad Alfassa 2016-08-25 21:10:03 UTC
I'm really sorry for the noise. Reopening.

It seems that my laptop was NOT running wayland when I tested this (even though I told it to, weird). I tested again and yeah, it's *definitely* not working, it shows an empty window instead of a preview.

I'm restoring proposal to make this a blocker bug too, reason specified in comment 5 still stands:

>  https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria#Default_application_functionality
> 
> sushi is arguably a "default application" or at least a part of it, and it
> will not function properly on Fedora 25 if Fedora 25 defaults to Wayland.

Comment 8 Kamil Páral 2016-08-26 08:20:05 UTC
I tested this with sushi-3.20.0-1.fc25 on a text file and an image, and while it does not crash, it only shows a grey window instead of showing the actual contents.

This is not arguably an application that "can be launched using the standard graphical mechanism of a release-blocking desktop", OTOH it can be launched from nautilus simply by pressing a space, so some people might consider it a part of basic functionality of nautilus.

Comment 9 Geoffrey Marr 2016-08-29 19:56:04 UTC
Discussed during the 2016-08-29 blocker review meeting: [1]

The decision to classify this bug as a RejectedBlocker was made as this functionality is not considered basic or integral for default-installed applications.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-08-29/f25-blocker-review.2016-08-29-16.00.txt

Comment 10 Christian Stadelmann 2016-08-29 19:59:24 UTC
I guess un-blocking WaylandRelated was an error, so I'm undoing it.

Comment 11 Christian Stadelmann 2016-08-29 20:00:09 UTC
(In reply to Christian Stadelmann from comment #10)
> I guess un-blocking WaylandRelated was an error, so I'm undoing it.

error → mistake

Comment 12 Matthias Clasen 2016-09-01 12:33:34 UTC
this should be fixed in sushi 3.21.91

Comment 13 Christian Stadelmann 2016-09-26 19:06:16 UTC
(In reply to Matthias Clasen from comment #12)
> this should be fixed in sushi 3.21.91

Yes, it is. I'd close the bug but I can't (permissions/owner)

Comment 14 Kamil Páral 2016-09-27 07:13:08 UTC
Confirmed fixed. Closing.


Note You need to log in before you can comment on or make changes to this bug.