Bug 1295131 - Ironic fails to install the boot loader on PERC RAID1 volume
Ironic fails to install the boot loader on PERC RAID1 volume
Status: CLOSED DUPLICATE of bug 1295132
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Lucas Alvares Gomes
Toure Dunnon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-02 12:23 EST by Gonéri Le Bouder
Modified: 2016-01-02 17:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-02 17:29:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gonéri Le Bouder 2016-01-02 12:23:13 EST
Description of problem:


Version-Release number of selected component (if applicable):

I use a DELL R730xd aith a PERC H730 Mini RAId controller. The machine has 12 hard drives. The two last ones are aggregated in a RAID1 virtual drive.
This virtual drive is the bootable device. I took some screenshot of the RAID configuration.

I use the last poodles OSP-d 2015-12-03.1 / OSP 2015-12-22.2 with the following images:
mburns/8.0/2015-12-03.1/images/deploy-ramdisk-ironic.tar
mburns/8.0/2015-12-03.1/images/ironic-python-agent.tar
mburns/8.0/2015-12-03.1/images/overcloud-full.tar

Kernel see the two drives of the RAID (sda and sdb) instead of just one virtual disk. Ironic fails to install the boot loader. The machine will restart on the old grub and fail to boot.

I tried to create a new RAM disk from the master branch of disk-imagebuild ( f389b3a04d75a35bb99ac68d13eaaa634cba7650 ) with the following command:
./bin/ramdisk-image-create -o deploy.ramdisk --ramdisk-element dracut-ramdisk ironic-agent centos7
And I get the same issue.

How reproducible:

Use "nova boot" to deploy a bare-metal node on this server.


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Gonéri Le Bouder 2016-01-02 17:29:44 EST

*** This bug has been marked as a duplicate of bug 1295132 ***

Note You need to log in before you can comment on or make changes to this bug.