Bug 1295136 - caja-terminal doesn't honor color preferences
caja-terminal doesn't honor color preferences
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: caja-terminal (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-02 13:33 EST by Dennis W. Tokarski
Modified: 2016-04-08 11:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: caja-terminal-0.9.1-1.fc24 caja-terminal-0.9.1-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-03 13:56:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis W. Tokarski 2016-01-02 13:33:59 EST
Description of problem:
  caja-terminal wants to show grey characters on a black background,
and that can't be changed via the preferences menu.


Version-Release number of selected component (if applicable):
  caja-terminal-0.9-1.fc23.x86_64

How reproducible:
  Always.


Steps to Reproduce:
1. Open a caja window, then click on preferences.
2. Pick the colors tab, and use any available means to change the
   font color to anything but white. The preview text will change
   to the selected color.
3. Close preferences and observe that the terminal pane font is
   still white.
4. Open preferences->colors again, and observe that all color
   buttons are black and the palette selection drop-down is
   blank. (Selecting a palette from the dropdown menu will restore
   colors in the color buttons)

Actual results:
  See above: terminal pane font color doesn't change.

Expected results:
  Terminal pane font color should be changed according to the
  preferences selection; palette selector should not switch to
  no palette selected.

Additional info:
  This has the feel of someone having "cleaned up" some "ugly"
  (but working) code without thinking too much or testing it
  afterward.

  Font size selection is also broken. The preferences->font tab
  always shows the current font as monospace 10 even when the
  actual font is something else. Making another selection will
  change the font in the terminal pane, but if you want to change
  back to monospace 10, you have to pick something else, then
  without closing the preferences pane reselect monospace 10.
  Then close preferences and the terminal pane text will revert.

  Color selection definitely worked in Fedora 20, and I'm pretty sure
  font selection worked right.  I don't remember if the "show scrollbar"
  option worked in F20, but it too is broken now.

  Manual editing of the configuration file is a workaround so long as
  you stay out of the preferences menu.
Comment 1 Wolfgang Ulbrich 2016-01-02 20:58:43 EST
I suggest to file out a report at new upstream
https://github.com/yselkowitz/caja-terminal
Update was needed because old version depends on python-caja-1.4.0 which is outdated since a long time.
Btw. i see a scrollbar after close/open a new caja window.
Comment 2 Dennis W. Tokarski 2016-01-02 23:41:56 EST
A little more information I just found...

My old ~/.config/caja-terminal/caja-terminal.conf which works has
this in it:

[COLOR]
        text = "#0fa5fe7a9996"
        background = "#000000"
        palettename = "Tango"

After trying to change the text color using preferences->colors,
it becomes:

[COLOR]
       	text = "Gdk.Color(red=50372, green=41120, blue=0)"
        background = "#000000"
        palettename = "Tango"

So it looks like there was an attempt to modify the configuration
file format. caja-terminal can read and act on the old format, then
writes out the new one but doesn't know what to do with it.

And thanks, Wolfgang, I will try to report to the upstream folks.
I'm now seeing the scrollbar behavior working as you describe. Huh.
I was sure I did that same thing before and it did nothing. Oh well.
Comment 3 Dennis W. Tokarski 2016-01-26 20:43:17 EST
Hey Wolfgang, I tried reporting upstream and see no
signs of life there. Can you wake anyone up?
Comment 4 Wolfgang Ulbrich 2016-02-27 08:50:14 EST
I called caja-terminal dev via irc a while ago, he promised to look into it.
Comment 5 Dennis W. Tokarski 2016-03-13 22:05:48 EDT
Hi Wolfgang, thanks. No action over there yet but I appreciate your trying.
Cheers!
Comment 6 Fedora Update System 2016-03-30 05:11:15 EDT
caja-terminal-0.9.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a56e56ba51
Comment 7 Fedora Update System 2016-03-30 05:11:22 EDT
caja-terminal-0.9.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4aeba65526
Comment 8 Fedora Update System 2016-03-30 18:25:54 EDT
caja-terminal-0.9.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4aeba65526
Comment 9 Fedora Update System 2016-03-30 18:55:08 EDT
caja-terminal-0.9.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a56e56ba51
Comment 10 Dennis W. Tokarski 2016-04-02 14:00:54 EDT
Hi Wolfang,

This works. Thanks!

There is something odd, though. If I set the text and background
colors in the gui preferences to be #10FF99 and #303030, then what
I see in the configuration file afterward is:

[COLOR]
       	text = "#1010ffff9999"
        background = "#303030303030"

...which is very strange, though it seem functionally OK.

Cheers!

--Dennis
Comment 11 Yaakov Selkowitz 2016-04-03 00:04:24 EDT
(In reply to Dennis W. Tokarski from comment #10)
> Hi Wolfang,
> 
> This works. Thanks!
> 
> There is something odd, though. If I set the text and background
> colors in the gui preferences to be #10FF99 and #303030, then what
> I see in the configuration file afterward is:
> 
> [COLOR]
>        	text = "#1010ffff9999"
>         background = "#303030303030"

GdkColor uses a 16-bit depth internally:

https://developer.gnome.org/gdk3/stable/gdk3-Colors.html
Comment 12 Fedora Update System 2016-04-03 13:56:57 EDT
caja-terminal-0.9.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2016-04-08 11:55:03 EDT
caja-terminal-0.9.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.