Bug 129515 - Installation of RHEL 3.0 U2 on EM64T (x86_64) servers report only UP kernel config being loaded/
Installation of RHEL 3.0 U2 on EM64T (x86_64) servers report only UP kernel c...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-09 17:40 EDT by Heather Conway
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-09 17:41:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heather Conway 2004-08-09 17:40:36 EDT
Description of problem:
The initial nstallation of RHEL 3.0 U2 on EM64T (x86_64) servers
report only UP kernel config being loaded.  Even though the server has
2 CPUs, the v2.4.21-15.EL kernel config is being loaded, not the
v2.4.21-15.ELsmp.
The CPUs are being reported twice in /proc/cpuinfo, ie.  if there is 1
CPU, two are reported and if there are 2 CPUs, then four are reported.

Version-Release number of selected component (if applicable):



How reproducible:
Every time.


Steps to Reproduce:
Install RHEL 3.0 x86_64 on any EM64T capable system with either 3.0GHz
or 3.4GHz CPUs.
  
Actual results:
The kernel config reports itself as UP, instead of SMP, even when
multiple CPUs are installed in the host.

Expected results:


Additional info:
Comment 1 Arjan van de Ven 2004-08-09 17:41:52 EDT
the kernel doesn't report UP; for example 
cat /boot/config-`uname -r` | grep SMP
will show SMP.
Comment 2 Heather Conway 2004-08-09 17:48:40 EDT
So the v2.4.21-15.EL kernel will support the SMP and highmem systems
in the same kernel, correct?  Therefore, for both EM64T and for AMD64
systems, only the v2.4.21-15.EL kernel need be selected, not the
v2.4.21-15.ELsmp, correct?
Thanks.

Comment 3 Arjan van de Ven 2004-08-09 17:50:21 EDT
for amd64 we decided to ship 2 kernel binaries, because UP amd64 boxes
do exist while for em64t, due to hyper threading, they don't.

Btw you cannot and should not determine the value of CONFIG_SMP based
on the kernel name.
Comment 4 Heather Conway 2004-08-09 17:50:45 EDT
Got it...thanks.

Note You need to log in before you can comment on or make changes to this bug.