Bug 129518 - Require pango-1.5
Require pango-1.5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgnomeprint22 (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-09 19:06 EDT by Dave Malcolm
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-11 17:50:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2004-08-09 19:06:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
When trying print preview of an email in Evolution, the program bombs
out with this error:
(evolution:6165): GnomePrintCupsPlugin-WARNING **: The ppd file for
the CUPS printer hplj1 could not be loaded.
Error while reading shared library symbols:
: No such file or directory.
Error while reading shared library symbols:
: No such file or directory.
Error while reading shared library symbols:
: No such file or directory.
Error while reading shared library symbols:
: No such file or directory.
 
(evolution:6165): GnomePrintCupsPlugin-WARNING **: iconv does not
support ppd character encoding: ISOLatin1, trying CSISOLatin1
 
(evolution:6165): GnomePrintCupsPlugin-WARNING **: The ppd file for
the CUPS printer mchp could not be loaded.
 
(evolution:6165): GnomePrintCupsPlugin-WARNING **: The ppd file for
the CUPS printer nolp could not be loaded.
/usr/bin/evolution: error while loading shared libraries:
/usr/lib/libgtkhtml-3.1.so.11: undefined symbol:
pango_font_metrics_get_underline_thickness
 
Program exited with code 0177.

Versions of packages installed:
libgnomeprint22-2.7.1-1
gtkhtml3-3.3.0-1
pango-1.4.0-2
evolution-1.5.92.1-1
evolution-data-server-0.0.97-2

It appears that Pango 1.5 is required by either libgnomeprint, or by
gtkhtml3, and I only have 1.4, so I'm guessing this simply needs an
extra Requires line in one of the spec files.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select an email in Evolution
2. Select "Print Preview"
3. Watch Evolution bail out with the Pango/gtkhtml3 problem described
above
    

Expected Results:  A beautiful preview of my email.

Additional info:
Comment 1 Owen Taylor 2004-08-10 09:46:14 EDT
libgnomeprint
Comment 2 Dave Malcolm 2004-08-11 17:50:47 EDT
I've added an explicit Pango>=1.5 dependency to libgnomeprint22 and
rebuilt into dict-fc3

Note You need to log in before you can comment on or make changes to this bug.