Bug 1295195 - SELinux is preventing mkdir from 'write' accesses on the directory /.
SELinux is preventing mkdir from 'write' accesses on the directory /.
Status: CLOSED DUPLICATE of bug 1046468
Product: Fedora
Classification: Fedora
Component: esmtp (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
abrt_hash:20e45b29c920fe786ce10cfcd20...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-03 07:38 EST by hx
Modified: 2016-01-05 08:29 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-05 08:29:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hx 2016-01-03 07:38:33 EST
Description of problem:
SELinux is preventing mkdir from 'write' accesses on the directory /.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that mkdir should be allowed write access on the  directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep mkdir /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:system_mail_t:s0
Target Context                system_u:object_r:root_t:s0
Target Objects                / [ dir ]
Source                        mkdir
Source Path                   mkdir
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           filesystem-3.2-35.fc23.x86_64
Policy RPM                    selinux-policy-3.13.1-158.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.8-300.fc23.x86_64 #1 SMP Tue
                              Dec 15 16:49:06 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2016-01-03 14:37:18 EET
Last Seen                     2016-01-03 14:37:18 EET
Local ID                      d3d8ae38-1f1c-44cc-9385-9d5f4e268ffa

Raw Audit Messages
type=AVC msg=audit(1451824638.189:704): avc:  denied  { write } for  pid=7930 comm="mkdir" name="/" dev="dm-1" ino=2 scontext=system_u:system_r:system_mail_t:s0 tcontext=system_u:object_r:root_t:s0 tclass=dir permissive=0


Hash: mkdir,system_mail_t,root_t,dir,write

Version-Release number of selected component:
selinux-policy-3.13.1-158.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.8-300.fc23.x86_64
type:           libreport

Potential duplicate: bug 1046468
Comment 1 Lukas Vrabec 2016-01-05 08:29:34 EST

*** This bug has been marked as a duplicate of bug 1046468 ***

Note You need to log in before you can comment on or make changes to this bug.