Bug 1295212 - engine-setup fails with error if you install just containers
engine-setup fails with error if you install just containers
Status: CLOSED DUPLICATE of bug 1318986
Product: ovirt-engine
Classification: oVirt
Component: Setup.Engine (Show other bugs)
x86_64 Linux
medium Severity unspecified (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Simone Tiraboschi
Pavel Stehlik
Depends On:
  Show dependency treegraph
Reported: 2016-01-03 11:46 EST by Barak Korren
Modified: 2016-04-29 12:01 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-04-29 12:01:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.0?
rule-engine: planning_ack+
sbonazzo: devel_ack+
rule-engine: testing_ack?

Attachments (Terms of Use)
Log file (1.38 MB, text/plain)
2016-01-03 11:46 EST, Barak Korren
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 52602 master ABANDONED packaging: setup: different fixes when don't configure the engine 2016-04-29 12:00 EDT

  None (edit)
Description Barak Korren 2016-01-03 11:46:58 EST
Created attachment 1111186 [details]
Log file

Description of problem:
engine-setup fails with error if you install just containers and tell it to nof install other components such as engine or DWH.

Version-Release number of selected component (if applicable):


The following output shows both the interactive input to the setup script as well as the failed output:

# engine-setup 
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-jboss.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20160103104757-s2t12b.log
          Version: otopi-1.4.0 (otopi-1.4.0-1.el7.centos)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization
          --== PRODUCT OPTIONS ==--
          Deploy Cinder container on this host (Yes, No) [Yes]: no
          Deploy Glance container on this host (Yes, No) [Yes]: yes
[ INFO  ] Unable to find an active docker daemon
          To continue with this setup the docker daemon should be active.
          Would you like to start it and continue with Setup? (Yes, No) [Yes]: yes
[ INFO  ] Starting Docker
          Configure Engine on this host (Yes, No) [Yes]: no
          Configure VM Console Proxy on this host (Yes, No) [Yes]: no
          Configure WebSocket Proxy on this host (Yes, No) [Yes]: no
          --== PACKAGES ==--
[ INFO  ] Checking for product updates...
[ INFO  ] No product updates found
          --== ALL IN ONE CONFIGURATION ==--
          --== NETWORK CONFIGURATION ==--
          Host fully qualified DNS name of this server [ovirt-test]: 
[WARNING] Host name ovirt-test has no domain suffix
          Setup can automatically configure the firewall on this system.
          Note: automatic configuration of the firewall may overwrite current settings.
          Do you want Setup to configure the firewall? (Yes, No) [Yes]: 
[ INFO  ] firewalld will be configured as firewall manager.
          --== DATABASE CONFIGURATION ==--
          --== STORAGE CONFIGURATION ==--
          Default SAN wipe after delete (Yes, No) [No]: 
          --== PKI CONFIGURATION ==--
          --== APACHE CONFIGURATION ==--
          --== SYSTEM CONFIGURATION ==--
          --== MISC CONFIGURATION ==--
          --== END OF CONFIGURATION ==--
[ INFO  ] Stage: Setup validation
          --== CONFIGURATION PREVIEW ==--
          Default SAN wipe after delete           : False
          Firewall manager                        : firewalld
          Update Firewall                         : True
          Host FQDN                               : ovirt-test
          Deploy Glance container                 : True
          Deploy Cinder container                 : False
          Engine installation                     : False
          Configure VMConsole Proxy               : False
          Configure WebSocket Proxy               : False
          Please confirm installation settings (OK, Cancel) [OK]: 
[ INFO  ] Stage: Transaction setup
[ INFO  ] Stopping engine service
[ INFO  ] Stopping ovirt-fence-kdump-listener service
[ INFO  ] Stage: Misc configuration
[ INFO  ] Stage: Package installation
[ INFO  ] Stage: Misc configuration
[ INFO  ] Pulling rabbitmq
[ INFO  ] Pulling mariadbdata
[ INFO  ] Pulling mariadbapp
[ INFO  ] Pulling keystone
[ INFO  ] Pulling glance-registry
[ INFO  ] Pulling glance-api
[ INFO  ] Creating rabbitmq
[ INFO  ] Starting rabbitmq
[ INFO  ] Creating mariadbdata
[ INFO  ] Starting mariadbdata
[ INFO  ] Creating mariadbapp
[ INFO  ] Starting mariadbapp
[ INFO  ] Creating keystone
[ INFO  ] Starting keystone
[ INFO  ] Creating glance-registry
[ INFO  ] Starting glance-registry
[ INFO  ] Creating glance-api
[ INFO  ] Starting glance-api
[ ERROR ] Failed to execute stage 'Misc configuration': 'NoneType' object has no attribute 'execute'
[ INFO  ] Yum Performing yum transaction rollback
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20160103104757-s2t12b.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20160103105847-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed

Additional Info:
* Despite the failure the Glance containers are up and running, and the service works
* Setup log attached
Comment 1 Doron Fediuck 2016-01-10 10:55:17 EST
What kind of deployment is this with no engine?
Comment 2 Barak Korren 2016-01-10 11:56:29 EST
(In reply to Doron Fediuck from comment #1)
> What kind of deployment is this with no engine?

Deploying a stand-alone Glance server to connect to the engine later. Same logic as setting up a stand-alone DWH.
(In may specific case, I was doing this to dog-food for 'glance.ovirt.org')
Comment 3 Mike McCune 2016-03-28 19:37:25 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Simone Tiraboschi 2016-04-29 12:01:37 EDT

*** This bug has been marked as a duplicate of bug 1318986 ***

Note You need to log in before you can comment on or make changes to this bug.