Bug 129523 - xfs font Times New Roman broken (squished together) in OpenOffice
xfs font Times New Roman broken (squished together) in OpenOffice
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-09 21:05 EDT by don
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-04 00:01:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description don 2004-08-09 21:05:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
While using Openoffice on (rh9|core2|core3t1) to open a document in
times new roman the text is squished together. (OO 1.0 worked) I see a
bunch of complaints in syslog:

syslog: xfs[562]: FreeType: couldn't open face
/usr/X11R6/lib/X11/fonts/latin2/Type1/timenrm_.pfb: 1

Openoffice developers say:
"The syslog says it. FreeType was unable to operate this font. 
I remember we once examined this font and the only thing I recall is
that is was broken.

Now the difference to OO.o 1.0 is that newer versions utilize the
systems libfreetype and not the own OO.o provided and "hand-tuned"
version."

Full data including screenshot and data file:
http://www.openoffice.org/issues/show_bug.cgi?id=31808

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run Openoffice > 1.1
2. Open test document at url
3. Look at screen
    

Actual Results:  document unreadable

Expected Results:  document readable

Additional info:

They blame you. I'm sure you'll blame them. At least look at it first,
maybe there is a problem with the system font.
Comment 2 Mike A. Harris 2004-10-12 02:56:28 EDT
The font refered to in this report is a known broken font.  Simply
remove this font from the system and the problem should no longer
occur.  Alternatively, replace the font with a known good version
of this font, and the problem should also be fixed.

If you continue to experience this problem, please use the X.Org
and/or XFree86 mailing lists to discuss the issue with other users
and/or developers.

Alternatively, you can file a bug report in X.Org bugzilla if you
would like X.Org X developers to give an opinion on this issue
as well:   http://bugs.freedesktop.org "xorg" component.

Setting status to "NOTABUG"
Comment 3 don 2004-10-14 15:43:09 EDT
If it's a "known broken font", then by definition, doesn't that make
it a bug? Shouldn't it be removed from the distribution, so that
everyone can benefit from the fix? Isn't this the place to report bugs
in the xorg-x11 component AS INSTALLED FROM THE DISTRIBUTION. What
you're saying seems to be that since everyone has the same bug, that
makes it not a bug.
Comment 4 Mike A. Harris 2004-12-03 23:40:08 EST
The timenrm_.pfb font is not part of X.Org X11, so "xorg-x11"
component is not the correct place to report bugs in the
timenrm_.pfb font.  If you are not sure what component to
choose for a particular issue you are experiencing however,
you can file bugs against the "distribution" component, and
an engineer will review the issue and reassign it to the
correct component.  I have manually confirmed this font is
not part of X.Org, however I'm also unable to find it installed
on any of 9 different systems I have locally, so I'm not sure
if we even ship it or not.

Can you run the following command, and indicate the results
returned:

rpm -qf /usr/X11R6/lib/X11/fonts/latin2/Type1/timenrm_.pfb

This will give the name of the RPM which contains this font.

Thanks in advance.
Comment 5 Mike A. Harris 2004-12-04 00:01:15 EST
After doing some more research, I have discovered the origin
of the font:  /usr/X11R6/lib/X11/fonts/latin2/Type1/timenrm_.pfb

It comes from the RPM package:  XFree86-ISO8859-2-Type1-fonts

XFree86-ISO8859-2-Type1-fonts is no longer part of the operating
system, and was last shipped in Red Hat Linux 7.1 from what it
appears in our internal build trees.  So this font was removed
from the OS already several years ago.

Presumeably, you have upgraded your system from an older OS
release, and still had the broken font package installed from the
earlier release.  I've just added an Obsoletes tag to our
xorg-x11-base-fonts subpackage, which will force this old broken
font rpm to be automatically uninstalled upon OS upgrades or
xorg-x11 updates, however that wont occur until our next
set of xorg-x11 rpms are released and people upgrade to them.

Since we do not supply this font since Red Hat Linux 7.1, and
it is a bug in the fonts themselves, I'm closing this bug as
"CURRENTRELEASE", as technically it's been fixed since RHL 7.2
when the fonts were removed.  If memory serves correct, judging
by the XFree86 and xorg-x11 rpm spec files, there used to be
an Obsoletes line forcing the removal of this font rpm before,
which seems to have gotten dropped at some point, possibly
in the transition from XFree86 to X.org.  Nonetheless, I've put
it back, so upgrades should remove the font from now on.

The side effect of that, is anyone using any of those fonts
will no longer have them after upgrades, but I don't see that
as a problem because we haven't supported those for several
years now, plus they are still available for download from
various places should someone require them at all.

The interim workaround, is to uninstall the
XFree86-ISO8859-2-Type1-fonts package manually with 'rpm -e --nodeps'


font rpm.
Comment 6 Mike A. Harris 2004-12-04 00:17:04 EST
A bit more information for completeness and accuracy:

The XFree86-ISO8859-2-Type1-fonts package was renamed to
fonts-ISO8859-2-Type1-fonts in RHL 7.2, since it was not
from XFree86.org, and did not contain any XFree86 supplied
fonts.  It remained in the OS until RHL 7.3 after which
it was removed entirely from what I can see.  Just the Type1
fonts were removed from the src.rpm

So you may need to "rpm -e fonts-ISO8859-2-Type1" as well.

Note You need to log in before you can comment on or make changes to this bug.