Bug 1295241 - params missing from overcloud_deploy.py [NEEDINFO]
params missing from overcloud_deploy.py
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity urgent
: ---
: 10.0 (Newton)
Assigned To: RHOS Maint
Shai Revivo
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-03 17:29 EST by Jon Thomas
Modified: 2016-10-04 14:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-04 14:45:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
calfonso: needinfo? (jthomas)


Attachments (Terms of Use)

  None (edit)
Description Jon Thomas 2016-01-03 17:29:40 EST
Updated to 12/10 drop and attempted a reinstall of overcloud. Deployment failed.  Realized that although the stack was deleted and "nova list" showed no servers, ironic still had instance UUIDs associated with each hardware.  We cleared up the instance UUIDs by doing another retrospective/scan.   However, the deployment attempts now failed right away due to anther error: missing cloud image. Nothing was changed in undercloud’s openstack. Flavors and images were the same.  After a lot of digging, I verified that this was due to the update.  I noticed that one of the modules, overcloud_deploy.py, used to have block of parameters hardcoded and now they are removed.  such as:

     controllerImage': 'overcloud-full',
    'NovaImage': 'overcloud-full',
    'BlockStorageImage': 'overcloud-full',
    'SwiftStorageImage': 'overcloud-full',
    'CephStorageImage': 'overcloud-full',
    'OvercloudControlFlavor': 'baremetal',
    'OvercloudComputeFlavor': 'baremetal',
    'OvercloudBlockStorageFlavor': 'baremetal',
    'OvercloudSwiftStorageFlavor': 'baremetal',
    'OvercloudCephStorageFlavor': 'baremetal'

I added some of the params back in and got beyond the immediate halts cause by missing/required params.  I did not add them ALL back in (read on please).
 
The deployment would go on 2-3 hours and never seem to get to some of the phases where you could see step1, step2, etc… Noticed, per ironic, that they system are rebooted and also  noticed that they are indeed getting a new provisioning ip (nova list from undercloud). As 2-3 hours would pass noticed that IP for the servers does change again giving me the impression that stack deployment is retrying.  But If I ssh’d to the new IP, even after 2 hours, I see the old OS/deployment.
 
I also restored just that module in its entirety, and tried a deployment.But similar result.
Comment 6 James Slagle 2016-01-04 11:45:47 EST
The defaults for the image and flavor name parameters were moved from the
client (overcloud_deploy.py) to tripleo-heat-templates directly (in
overcloud-without-mergepy.yaml) in the 7.2 release of director.

What I expect is happening then is that they yum updated the undercloud, and
got the new client code, but are still using old tripleo-heat-templates. Do
they have a local copy of the templates they might be using? If so, they need
to make a new copy of /usr/share/openstack-tripleo-heat-templates, and
incorporate any changes they had made to the templates into that new copy. Then
try a new deployment with that new copy.
Comment 7 chris alfonso 2016-01-04 12:35:30 EST
Jon, once you check the templates to make sure they are updated, please let us know in this bug what you find. Thanks.
Comment 8 Mike Burns 2016-04-07 17:03:37 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 10 Jaromir Coufal 2016-10-04 14:45:48 EDT
Closing since it should be resolved per comment #6. Please re-open if still experiencing some issues.

Note You need to log in before you can comment on or make changes to this bug.