Bug 129526 - bash handles 'r' vi binding command incorrectly at end-of-line
bash handles 'r' vi binding command incorrectly at end-of-line
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-09 21:40 EDT by Paul Iadonisi
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 3.0-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-10 04:45:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Iadonisi 2004-08-09 21:40:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803 Galeon/1.3.16

Description of problem:
The 'r' command of the vi editing mode when used on the last character
of a line, after modifying the last character then swaps the last two
characters.

Version-Release number of selected component (if applicable):
bash-3.0-2

How reproducible:
Always

Steps to Reproduce:
1. Launch a bash shell
2. Set editing mode to 'vi' with 'set -o vi'
3. Type any command, but don't hit return
4. Enter vi-command mode by hitting the escape key
5. Go to the end of line with the '$' command
6. Type 'r' to change the last character
7. Type any character (other than what the character already is)
    

Actual Results:  The last two characters are inexplicably swapped
after the last character is changed.

Expected Results:  The last two characters should not be swapped.

Additional info:

This probably a readline 5.0 bug, but since readline 5.0 is not
included as a separate component (yet), then I believe this belongs
here as a bash bug.
Comment 1 Tim Waugh 2004-08-10 04:45:01 EDT
Thanks for the report.  This is indeed a readline bug.  Fixed package
is bash-3.0-4.

Note You need to log in before you can comment on or make changes to this bug.