Bug 1295275 - Update comments in vncserver configuration file example
Update comments in vncserver configuration file example
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tigervnc (Show other bugs)
7.2
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jan Grulich
Desktop QE
:
Depends On:
Blocks: 1203710 1297830 1313485
  Show dependency treegraph
 
Reported: 2016-01-03 23:47 EST by amit yadav
Modified: 2016-11-03 21:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 21:29:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description amit yadav 2016-01-03 23:47:50 EST
Description of problem:

$ more /lib/systemd/system/vncserver@.service
  # The vncserver service unit file
  #
  # Quick HowTo:
  # 1. Copy this file to /etc/systemd/system/vncserver@.service
  # 2. Edit <USER> and vncserver parameters appropriately
  #   ("runuser -l <USER> -c /usr/bin/vncserver %i -arg1 -arg2")
  # 3. Run `systemctl daemon-reload`
  # 4. Run `systemctl enable vncserver@:<display>.service`


In step 2. of comment section, actually 2 lines need to be modified instead of just the first line

("runuser -l <USER> -c /usr/bin/vncserver %i -arg1 -arg2")

It should be 

ExecStart=/sbin/runuser -l USER -c "/usr/bin/vncserver %i -geometry 1280x1024"
PIDFile=/home/USER/.vnc/%H%i.pid

Please update the Quick HowTo in comments to be consistent with RHEL documentation (https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/System_Administrators_Guide/ch-TigerVNC.html).

Version-Release number of selected component (if applicable):
tigervnc-server-1.3.1-3.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. N.A.

Actual results:
The vncserver configuration file suggest to modify <USER> in only one line. 
"runuser -l <USER> -c /usr/bin/vncserver %i -arg1 -arg2"

Expected results:
The vncserver configuration file should suggest to modify <USER> in following two lines:

ExecStart=/sbin/runuser -l USER -c "/usr/bin/vncserver %i -geometry 1280x1024"
PIDFile=/home/USER/.vnc/%H%i.pid
Comment 2 Jan Grulich 2016-01-19 02:59:27 EST
Easy fix, can be fixed in RHEL 7.3.
Comment 3 Jan Grulich 2016-03-24 05:53:58 EDT
Fixed in tigervnc-1.3.1-5.el7.
Comment 7 errata-xmlrpc 2016-11-03 21:29:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2237.html

Note You need to log in before you can comment on or make changes to this bug.