Bug 1295299 - glusterfs fuse mount session hangs indefinitely when a file create progressively fills up the hot tier completely
glusterfs fuse mount session hangs indefinitely when a file create progressiv...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 3.1.2
Assigned To: Bug Updates Notification Mailing List
krishnaram Karthick
: Regression, ZStream
Depends On: 1219794
Blocks: Gluster-HC-1
  Show dependency treegraph
 
Reported: 2016-01-04 02:10 EST by nchilaka
Modified: 2016-09-17 11:43 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:06:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nchilaka 2016-01-04 02:10:15 EST
Description of problem:
===========================
Suppose a hot disk(assume 1GB disk) is about 85%(~850MB) filled(not hit minfree), and I use dd command to create a file which will now exceed the total disk capacity 100%(300MB file), the file create starts off but , after sometime the fuse mount session hangs indefinetly.

This is a regression found during validation of bz#1291566


Version-Release number of selected component (if applicable):
===============================
3.7.5-13



Note:Refer BZ#1291566 for more info or steps
Comment 3 Nithya Balachandran 2016-01-08 05:48:23 EST
Is this the same issue seen in write-behind ?
Comment 5 Joseph Elwin Fernandes 2016-01-08 12:22:00 EST
Even there is a crash : https://bugzilla.redhat.com/show_bug.cgi?id=1297004
Comment 6 Raghavendra G 2016-01-11 01:04:01 EST
Yes. Hang similar to bz 1219794. Most likely a duplicate. But if you want to confirm, can you take statedump of inodes of the client process after hang? I can confirm with inode statedump.
Comment 7 krishnaram Karthick 2016-01-29 05:19:17 EST
Issue is no more seen in build glusterfs-3.7.5-17.el7rhgs.x86_64.

Steps followed to verify the bug:
1) Create a tiered volume and fill hot disk
2) As new file get created, old files kept demoting
3) No hangs were seen from the client

Moving the bug to verified.
Comment 9 errata-xmlrpc 2016-03-01 01:06:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.