Bug 1295328 - codeblocks contain problematic content
codeblocks contain problematic content
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: codeblocks (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jens Lody
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2016-01-04 03:16 EST by mejiko
Modified: 2016-08-14 01:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: codeblocks-16.01-1.fc24 codeblocks-16.01-1.fc23 codeblocks-13.12-24.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-08 16:27:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mejiko 2016-01-04 03:16:05 EST
Hello.

codeblocks included non-free image. 
This is "Lena" (Lenna) image. (JPG file)

This file license (Copyright) is non-free, and this content is violate Fedora Packaging Guideline.

https://fedoraproject.org/wiki/Packaging:Guidelines#Code_Vs_Content

This files contain source RPM (source archive) and binary RPM.
Thanks.
Comment 1 Dan Horák 2016-01-04 03:48:56 EST
Can you post the path to the file and why do you think it is non-free (like a reference to its license), please?
Comment 2 mejiko 2016-01-04 04:08:37 EST
Thank you reply.

File path is:

"codeblocks-13.12/src/plugins/contrib/source_exporter/wxPdfDocument/samples/minimal/lena.jpg"

"codeblocks-13.12/src/plugins/scriptedwizard/resources/opencv/files/lena.jpg"


non-free Reason:

1) This file is copyrighted, and not fedora acceptable licensed content. 

Reference:

https://lintian.debian.org/tags/license-problem-non-free-img-lenna.html


Thanks.
Comment 3 Tom "spot" Callaway 2016-02-02 15:53:12 EST
The Lena/Lenna sample files were taken from a Playboy magazine scan. Despite widespread use, there is no permission from the copyright holder to distribute them. Just remove them from the source tarball (deleting them in %prep is not sufficient).
Comment 4 Jan Kurik 2016-02-24 09:13:06 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Tom "spot" Callaway 2016-07-25 12:06:30 EDT
Upstream has replaced the lenna files with freely licensed alternatives in their source control. I made an attempt to upgrade the Fedora package to at least that revision (10867), but it crashes on startup.
Comment 6 Jens Lody 2016-07-25 12:41:07 EDT
(In reply to Tom "spot" Callaway from comment #5)
> Upstream has replaced the lenna files with freely licensed alternatives in
> their source control. I made an attempt to upgrade the Fedora package to at
> least that revision (10867), but it crashes on startup.

I'm one of the upstream developers and also a Fedora package maintainer.
I will probably take over codeblocks in Fedora/Epel, as Dan's time is very limited.

The crash is already fixed in trunk (optimization-issue with wxProggrid).
And almost all Fedora related patches are in trunk too.Nevertheless I tend to update to the 16.01 release at the moment (and backport the change and probably some bug fixes), because the actual trunk needs c++11 and can not be used for Epel 5 and 6.

A working snapshot (aka nightly) can be installed from my copr: https://copr.fedorainfracloud.org/coprs/jenslody/codeblocks/

Jens
Comment 7 Tom "spot" Callaway 2016-07-25 13:16:03 EDT
How convenient that we cross paths then! I've recently added libcxx to EL5/6 and libcxxabi is awaiting review:

https://bugzilla.redhat.com/show_bug.cgi?id=1332306

If 16.01 had the lenna files removed, that would be the ideal scenario. I was trying to avoid having to make a custom source tarball, which is why I tried going to the svn checkout.

Since you're here, I'll leave the task to you. :)
Comment 8 Fedora Admin XMLRPC Client 2016-07-26 03:48:28 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Fedora Update System 2016-07-28 03:43:48 EDT
codeblocks-16.01-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-876fecb8cc
Comment 10 Fedora Update System 2016-07-28 03:44:17 EDT
codeblocks-16.01-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d63b2f5faf
Comment 11 Fedora Update System 2016-07-28 08:12:33 EDT
codeblocks-13.12-24.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-bfda0f8ad8
Comment 12 Fedora Update System 2016-07-28 23:55:45 EDT
codeblocks-16.01-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-876fecb8cc
Comment 13 Fedora Update System 2016-07-28 23:55:58 EDT
codeblocks-16.01-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d63b2f5faf
Comment 14 Fedora Update System 2016-07-29 03:19:17 EDT
codeblocks-13.12-24.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-bfda0f8ad8
Comment 15 Fedora Update System 2016-08-08 16:27:26 EDT
codeblocks-16.01-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2016-08-08 19:54:37 EDT
codeblocks-16.01-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2016-08-14 01:19:51 EDT
codeblocks-13.12-24.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.