Bug 1295397 - Rolling upgrades in ExampleConfigsIT and HotRodRollingUpgradesIT throws Unable to parse header
Rolling upgrades in ExampleConfigsIT and HotRodRollingUpgradesIT throws Unabl...
Status: CLOSED NOTABUG
Product: JBoss Data Grid 6
Classification: JBoss
Component: TestSuite, Server (Show other bugs)
6.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 7.0.0
Assigned To: Martin Vrabel
Martin Gencur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 05:56 EST by Martin Vrabel
Modified: 2016-07-13 19:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 08:28:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Vrabel 2016-01-04 05:56:22 EST
Description of problem:

Problem is the used hotrod.protocol.version durin rolling upgrades.
If not specified, the test use  DEFAULT_PROTOCOL_VERSION which is 2.3.

if we specify the  hotrod.protocol.version to be less or equal to 2.2 the the Rolling upgrade passes without a problem 

Stack trace:

[0m[31m11:34:44,377 ERROR [org.infinispan.server.hotrod.CacheDecodeContext] (HotRodServerWorker-3) ISPN005003: Exception reported: org.infinispan.server.hotrod.RequestParsingException: Unable to parse header
	at org.infinispan.server.hotrod.HotRodDecoder.readHeader(HotRodDecoder.scala:180) [infinispan-server-hotrod-6.3.0.Final-redhat-5.jar:6.3.0.Final-redhat-5]
	at org.infinispan.server.hotrod.HotRodDecoder.org$infinispan$server$hotrod$HotRodDecoder$$decodeHeader(HotRodDecoder.scala:70) [infinispan-server-hotrod-6.3.0.Final-redhat-5.jar:6.3.0.Final-redhat-5]
	at org.infinispan.server.hotrod.HotRodDecoder$$anonfun$decode$1.apply$mcV$sp(HotRodDecoder.scala:47) [infinispan-server-hotrod-6.3.0.Final-redhat-5.jar:6.3.0.Final-redhat-5]
	at org.infinispan.server.hotrod.HotRodDecoder.wrapSecurity(HotRodDecoder.scala:208) [infinispan-server-hotrod-6.3.0.Final-redhat-5.jar:6.3.0.Final-redhat-5]
	at org.infinispan.server.hotrod.HotRodDecoder.decode(HotRodDecoder.scala:45) [infinispan-server-hotrod-6.3.0.Final-redhat-5.jar:6.3.0.Final-redhat-5]
	at io.netty.handler.codec.ReplayingDecoder.callDecode(ReplayingDecoder.java:362) [netty-all-4.0.18.Final-redhat-1.jar:4.0.18.Final-redhat-1]
	at io.netty.handler.codec.ByteToMessageDecoder.channelRead(ByteToMessageDecoder.java:141) [netty-all-4.0.18.Final-redhat-1.jar:4.0.18.Final-redhat-1]
	at org.infinispan.server.hotrod.HotRodDecoder.org$infinispan$server$core$transport$StatsChannelHandler$$super$channelRead(HotRodDecoder.scala:31) [infinispan-server-hotrod-6.3.0.Final-redhat-5.jar:6.3.0.Final-redhat-5]
	at org.infinispan.server.core.transport.StatsChannelHandler$class.channelRead(StatsChannelHandler.scala:32) [infinispan-server-core-6.3.0.Final-redhat-5.jar:6.3.0.Final-redhat-5]
	at org.infinispan.server.hotrod.HotRodDecoder.channelRead(HotRodDecoder.scala:31) [infinispan-server-hotrod-6.3.0.Final-redhat-5.jar:6.3.0.Final-redhat-5]
	at io.netty.channel.DefaultChannelHandlerContext.invokeChannelRead(DefaultChannelHandlerContext.java:341) [netty-all-4.0.18.Final-redhat-1.jar:4.0.18.Final-redhat-1]
	at io.netty.channel.DefaultChannelHandlerContext.fireChannelRead(DefaultChannelHandlerContext.java:327) [netty-all-4.0.18.Final-redhat-1.jar:4.0.18.Final-redhat-1]
	at io.netty.channel.DefaultChannelPipeline.fireChannelRead(DefaultChannelPipeline.java:785) [netty-all-4.0.18.Final-redhat-1.jar:4.0.18.Final-redhat-1]
	at io.netty.channel.nio.AbstractNioByteChannel$NioByteUnsafe.read(AbstractNioByteChannel.java:116) [netty-all-4.0.18.Final-redhat-1.jar:4.0.18.Final-redhat-1]
	at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:494) [netty-all-4.0.18.Final-redhat-1.jar:4.0.18.Final-redhat-1]
	at io.netty.channel.nio.NioEventLoop.processSelectedKeysOptimized(NioEventLoop.java:461) [netty-all-4.0.18.Final-redhat-1.jar:4.0.18.Final-redhat-1]
	at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:378) [netty-all-4.0.18.Final-redhat-1.jar:4.0.18.Final-redhat-1]
	at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:350) [netty-all-4.0.18.Final-redhat-1.jar:4.0.18.Final-redhat-1]
	at io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:116) [netty-all-4.0.18.Final-redhat-1.jar:4.0.18.Final-redhat-1]
	at java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_79]
Caused by: org.infinispan.server.hotrod.UnknownVersionException: Unknown version:23
	at org.infinispan.server.hotrod.HotRodDecoder.readHeader(HotRodDecoder.scala:167) [infinispan-server-hotrod-6.3.0.Final-redhat-5.jar:6.3.0.Final-redhat-5]
	... 19 more

Version-Release number of selected component (if applicable):


How reproducible:

mvn clean verify -Dzip.dist=......jboss-datagrid-6.X.X-server.zip -Psuite.examples -Dit.test=ExampleConfigsIT#testHotRodRollingUpgrades

or 

mvn clean verify -Psuite.rolling.upgrades -Dzip.dist.old=.....jboss-datagrid-6.X.X-server.zip -Dzip.dist=.....jboss-datagrid-6.X.X-server.zip -Dit.test=HotRodRollingUpgradesIT

or


mvn clean verify -Psuite.rolling.upgrades.dist -Dzip.dist.old=.....jboss-datagrid-6.X.X-server.zip -Dzip.dist=.....jboss-datagrid-6.X.X-server.zip -Dit.test=HotRodRollingUpgradesIT

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Note You need to log in before you can comment on or make changes to this bug.