Bug 1295407 - Deployment fails: ERROR: The Parameter (CinderRbdPoolName) was not defined in template.
Deployment fails: ERROR: The Parameter (CinderRbdPoolName) was not defined in...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity high
: ga
: 8.0 (Liberty)
Assigned To: Giulio Fidente
Yogev Rabl
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 06:39 EST by Marius Cornea
Modified: 2016-04-07 17:44 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.7-5.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:44:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 250104 None None None 2016-01-04 10:23 EST

  None (edit)
Description Marius Cornea 2016-01-04 06:39:28 EST
Description of problem:
I am trying to do a RHOS8 deployment and passing the Ceph pool names into an environment files. Deployment fails because there is no CinderRbdPoolName defined in the template. 

This used to work with RHOS7.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.7-2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Try to deploy overcloud
openstack overcloud deploy \
    --templates ~/templates/my-overcloud \
    -e ~/templates/virt-ha-ceph.yaml \
    -e ~/templates/my-overcloud/environments/network-isolation.yaml \
    -e ~/templates/network-environment.yaml \
    -e ~/templates/firstboot-environment.yaml \
    -e ~/templates/ceph.yaml  \
    -e ~/templates/my-overcloud/environments/puppet-pacemaker.yaml

2. Contents of ~/templates/ceph.yaml:
stack@instack:~>>> cat ~/templates/ceph.yaml
parameters:
  # the following parameters enable Ceph backends for Cinder, Glance, and Nova
  CephClientUserName: openstack
  NovaEnableRbdBackend: true
  CinderEnableRbdBackend: true
  GlanceBackend: rbd
  NovaRbdPoolName: vms
  CinderRbdPoolName: volumes
  GlanceRbdPoolName: images

  # finally we disable the Cinder LVM backend
  CinderEnableIscsiBackend: false


Actual results:
stack@instack:~>>> time bash deploy.command
Deploying templates in the directory /home/stack/templates/my-overcloud
ERROR: The Parameter (CinderRbdPoolName) was not defined in template.

Expected results:
Deployment succeeds.
Comment 1 Alexander Chuzhoy 2016-01-04 10:44:01 EST
Same applies to Nova and Glance, i.e.:

ERROR: The Parameter (NovaRbdPoolName) was not defined in template.

ERROR: The Parameter (GlanceRbdPoolName) was not defined in template.
Comment 2 Giulio Fidente 2016-02-08 09:00:56 EST
hi,

in RHOS8 these should be passed via

  parameter_defaults:

and not

  parameters:

unfortunately the sample storage-environment.yaml file in RHOS7 used to have "parameters:" but the first will work with RHOS7 too.

Both the sample environment files puppet-ceph-external.yaml and storage-environment.yaml in RHOS8 use "parameter_defaults:" now.

Can you please confirm that this fixes the problem?
Comment 3 Giulio Fidente 2016-02-17 06:39:44 EST
Yogev I think you tested this as well recently and were able to customize the pool names?
Comment 5 Yogev Rabl 2016-03-06 04:32:30 EST
verification passed in openstack-tripleo-heat-templates-0.8.8-2.el7ost.noarch
Comment 7 errata-xmlrpc 2016-04-07 17:44:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.