Bug 1295412 - Engine upgrade with unfinished tasks is failing due to dwhd currently running
Engine upgrade with unfinished tasks is failing due to dwhd currently running
Status: CLOSED DUPLICATE of bug 1286441
Product: ovirt-engine
Classification: oVirt
Component: Setup.Engine (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity urgent (vote)
: ---
: ---
Assigned To: Sandro Bonazzola
Petr Matyáš
integration
:
Depends On:
Blocks: 1283944 RHEV3.6Upgrade
  Show dependency treegraph
 
Reported: 2016-01-04 07:28 EST by Petr Matyáš
Modified: 2016-01-07 03:56 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-07 03:56:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
gklein: ovirt‑3.6.z?
gklein: blocker?
pmatyas: planning_ack?
pmatyas: devel_ack?
pmatyas: testing_ack?


Attachments (Terms of Use)
engine and dwh logs (35.17 KB, application/x-gzip)
2016-01-04 07:28 EST, Petr Matyáš
no flags Details

  None (edit)
Description Petr Matyáš 2016-01-04 07:28:07 EST
Created attachment 1111478 [details]
engine and dwh logs

Description of problem:
I have an engine with task of creating new template from VM, I stop ovirt-engine (while the task is running) and run engine-setup with upgrade to 3.6.2-3. The task is found as not finished and setup finishes it (or at least it looks like that) but it doesn't mark the task as finished. But then the setup fails on: [ ERROR ] dwhd is currently running. But if I check the service, it's stopped.

Version-Release number of selected component (if applicable):
3.6.2-3

How reproducible:
always

Steps to Reproduce:
1. create template from VM
2. stop ovirt-engine service
3. run engine-setup with upgrade
4. let setup complete the task with creating template

Actual results:
failed setup

Expected results:
correct upgrade

Additional info:
Comment 1 Yedidyah Bar David 2016-01-04 07:47:28 EST
Perhaps duplicate of bug 1284438?
Comment 2 Petr Matyáš 2016-01-04 08:02:01 EST
I don't think so. Although you are right that error in dwhd log is the same as in bug 1286441 the flow is completely different.
Comment 3 Yedidyah Bar David 2016-01-04 08:08:05 EST
(In reply to Petr Matyáš from comment #2)
> I don't think so. Although you are right that error in dwhd log is the same

Does a restart of dwhd solve? see bug 1286441 comment 1.

> as in bug 1286441 the flow is completely different.

Not sure.

bug 1286441 is already on_qa, did this bug happen with the latest dwhd?
Comment 4 Petr Matyáš 2016-01-04 08:20:19 EST
I have engine on 3.6.1-7 and I'am upgrading to 3.6.2-3.
But now when I tried restarting dwhd service the upgrade continues. So yes, probably duplicate. Will see how it goes.
Anyway bug 1286441 is either not fixed or this is a new bug. I can test that one with latest build when the upgrade finishes.
Comment 5 Yedidyah Bar David 2016-01-07 03:56:44 EST
(In reply to Petr Matyáš from comment #4)
> I have engine on 3.6.1-7 and I'am upgrading to 3.6.2-3.
> But now when I tried restarting dwhd service the upgrade continues. So yes,
> probably duplicate. Will see how it goes.

Closing as duplicate for now. Please reopen if relevant. Thanks.

*** This bug has been marked as a duplicate of bug 1286441 ***

Note You need to log in before you can comment on or make changes to this bug.