Bug 1295419 - foreman-debug -m=0 to collect all logs
foreman-debug -m=0 to collect all logs
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Foreman Debug (Show other bugs)
6.1.5
All Linux
medium Severity medium (vote)
: Beta
: --
Assigned To: Lukas Zapletal
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Improvement, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 07:41 EST by Pavel Moravec
Modified: 2016-07-27 05:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:01:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12978 None None None 2016-04-22 11:42 EDT

  None (edit)
Description Pavel Moravec 2016-01-04 07:41:57 EST
Description of problem:
foreman-debug should have an option to collect all logs. It already has option -m to limit number of lines per file collected, but -m0 means files are emtpy ("tail -n0" is called).

Please fix -m 0 to collect whole file, not its zero-length tail.


Version-Release number of selected component (if applicable):
foreman-debug-1.7.2.49-1.el7sat.noarch


How reproducible:
100%


Steps to Reproduce:
1. foreman-debug -m 0
2. unpack the generated archive
3. wc foreman-debug-*/var/log/katello-installer/katello-installer.log



Actual results:
3. shows empty logfile collected


Expected results:
the collected log file should be the same like original


Additional info:
Comment 2 Bryan Kearney 2016-01-07 04:04:11 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/12978 has been closed
-------------
Pavel Moravec
Applied in changeset commit:51f005e139c09fdd37273ac408dc21a176431cda.
Comment 5 Kedar Bidarkar 2016-04-07 02:46:28 EDT
The collected log files are no longer empty.


oreman-installer]# ll
total 1512
-rw-r--r--. 1 root root    6782 Apr  7 02:38 capsule.log
-rw-r--r--. 1 root root    1212 Apr  7 02:38 foreman.log
-rw-r--r--. 1 root root 1523745 Apr  7 02:38 katello.1.log
-rw-r--r--. 1 root root    7400 Apr  7 02:38 katello.2.log
[root@katello1 foreman-installer]# pwd
/root/foreman-debug-7kzzK/var/log/foreman-installer


VERIFIED With sat62-snap6.0
Comment 7 errata-xmlrpc 2016-07-27 05:01:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.