Bug 1295436 - (CVE-2015-8508) CVE-2015-8508 bugzilla: cross-site scripting when generating a dependency graph
CVE-2015-8508 bugzilla: cross-site scripting when generating a dependency graph
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20151222,repor...
: Security
Depends On: 1295437
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 08:56 EST by Martin Prpič
Modified: 2016-05-31 02:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: bugzilla 4.2.16, bugzilla 4.4.11, bugzilla 5.0.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Prpič 2016-01-04 08:56:35 EST
Upstream Bugzilla fixed the following issue:

During the generation of a dependency graph, the code for the HTML image map is generated locally if a local dot installation is used. With escaped HTML characters in a bug summary, it is possible to inject unfiltered HTML code in the map file which the CreateImagemap function generates. This could be used for a cross-site scripting attack.

This issue was fixed in versions 4.2.16, 4.4.11, and 5.0.2.

Upstream bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=1221518
Comment 1 Martin Prpič 2016-01-04 08:56:55 EST
Created bugzilla tracking bugs for this issue:

Affects: fedora-all [bug 1295437]

Note You need to log in before you can comment on or make changes to this bug.