Bug 1295444 - Please split gtksink into subpackage, depchain makes KDE Plasma depend on gtk3
Please split gtksink into subpackage, depchain makes KDE Plasma depend on gtk3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gstreamer1-plugins-bad-free (Show other bugs)
23
All Linux
high Severity high
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
: Patch, Reopened
Depends On:
Blocks: depchain
  Show dependency treegraph
 
Reported: 2016-01-04 09:11 EST by Kevin Kofler
Modified: 2016-08-27 06:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: gstreamer1-plugins-bad-free-1.9.1-2.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-27 06:20:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix FTBFS, #1295444, #1267665, #1308290 (8.28 KB, patch)
2016-02-20 10:15 EST, Kevin Kofler
no flags Details | Diff

  None (edit)
Description Kevin Kofler 2016-01-04 09:11:40 EST
Description of problem:
gstreamer1-plugins-bad-free-1.6.1-2.fc23 introduced a dependency on gtk3. This introduces the dependency chain:
kwin → qt5-qtmultimedia → gstreamer1-plugins-bad-free → gtk3
which makes KDE Plasma (indirectly) depend on gtk3. Please split the gtksink that introduces this dependency into a subpackage.

Version-Release number of selected component (if applicable):
gstreamer1-plugins-bad-free-1.6.1-2.fc23
gstreamer1-plugins-bad-free-1.6.2-1.fc23
gstreamer1-plugins-bad-free-1.6.1-2.fc24
gstreamer1-plugins-bad-free-1.6.2-1.fc24
gstreamer1-plugins-bad-free-1.6.2-2.fc24

How reproducible:
Always

Steps to Reproduce:
1. dnf erase gtk3

Actual results:
kwin (and plasma-workspace and plasma-desktop) get removed.

Expected results:
kwin and other KDE Plasma stuff does NOT get removed when removing gtk3.

Additional info:
Addressing bug #1267665 at the same time would be appreciated, too. The fewer unwanted huge dependencies KDE Plasma has, the better.
Comment 1 Kevin Kofler 2016-01-04 09:14:45 EST
In case you wonder, the reason qt5-qtmultimedia needs gstreamer1-plugins-bad-free is the libgstphotography-1.0.so.0 library.
Comment 2 Kevin Kofler 2016-02-20 10:15 EST
Created attachment 1128805 [details]
Fix FTBFS, #1295444, #1267665, #1308290

The attached patch fixes this bug, bug #1267665, bug #1308290 and the FTBFS of the current Rawhide specfile.
Comment 3 Kevin Kofler 2016-08-14 08:19:39 EDT
I see you also did a F25 build, can you please file it in Bodhi? (It missed the cutoff for the direct push, all F25 builds have to go through Bodhi now.)
Comment 4 Fedora Update System 2016-08-19 07:14:28 EDT
gstreamer1-plugins-bad-free-1.9.1-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a1bc3f1930
Comment 5 Fedora Update System 2016-08-19 12:50:26 EDT
gstreamer1-plugins-bad-free-1.9.1-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a1bc3f1930
Comment 6 Fedora Update System 2016-08-27 06:19:56 EDT
gstreamer1-plugins-bad-free-1.9.1-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.