Bug 1295466 - CFME provides no diagnostic facility to track CFME or rails/ActiveRecord processing sequence associated with initial appliance injection into VMDB
CFME provides no diagnostic facility to track CFME or rails/ActiveRecord proc...
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
x86_64 Linux
medium Severity medium
: GA
: cfme-future
Assigned To: Gregg Tanzillo
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 10:36 EST by Thomas Hennessy
Modified: 2017-08-28 10:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-28 10:46:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Hennessy 2016-01-04 10:36:06 EST
Description of problem:there exists no diagnostic facility to trace the activities of the initial contact of a new CFME appliance into an existing VMDB, making the diagnosis of the root cause of  such a problem very difficult.


Version-Release number of selected component (if applicable):5.5.0.13


How reproducible:very


Steps to Reproduce:
1.Begin with an already existing and functioning database appliance
2. create a new appliance which will eventually connect to the existing VMDB of #1 above
3. before the database customization of the new appliance begins, enable evm and rails debug logging on the vmdb.yml.tmpl file in /var/www/miq/vmdb/config 
4. perform the normal processing to connect the new appliance to the existing external database.
5. review the evm.log and production.log files to see what has been logged.  Notice that logging begins well after the appliance has become associated (injected into the) VMDB.

Actual results:


Expected results:


Additional info:When this problem occurs with a customer environment, the only means so far identified to see the sql sequence of events is to enable sql statement tracing in the postgresql.conf file which is problematic if the failing environment is a production environment.
Comment 2 Chris Pelland 2017-08-28 10:46:52 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.