This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1295468 - Change in link behavior in lpfc driver on LPE31000 and LPE32000 HBAS with unqualified optics.
Change in link behavior in lpfc driver on LPE31000 and LPE32000 HBAS with unq...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: Red_Hat_Enterprise_Linux-Release_Notes-6-en-US (Show other bugs)
6.9
All Linux
high Severity high
: rc
: ---
Assigned To: Lenka Spackova
QE Internationalization Bugs
Jana Heves
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 10:37 EST by Laurie Barry
Modified: 2016-05-10 08:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
lpfc driver update With the latest update, LPE31000, LPE32000 HBAs, and all HBA variants of this architecture now detect and enable both Broadcom-ECD certified SFP and QSFP optics. For firmware rev 11.0.204.0 and later, unqualified optics are disabled, the network link shows `link down` state, and an error message is logged to the log file. The lpfc driver in Red Hat Enterprise Linux 6.8 displays the following message and the network link does not come up: 3176 Misconfigured Physical Port - Port Name [wwpn] Unknown event status [status] The users are recommended to use only Broadcom-ECD certified SFP and QSFP optics. If any of the 3176 messages are seen in the logs and the link does not come up, contact Broadcom-ECD technical support.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 08:18:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laurie Barry 2016-01-04 10:37:49 EST
Update the RHEL6.8 Release Notes with the following information.

Section Number and Name: Kernel Storage Drivers - Avago Emulex Fibrechannel driver - LPFC

Describe the issue: 
Change in link behavior in lpfc driver on LPE31000 and LPE32000 HBAS with unqualified optics.

LPE31000. LPE32000 HBAs and all variant HBAs of this architecture will:

Detect and enable both Avago or Emulex certified SFP and QSFP optics. 
For firmware rev 11.0.204.0 unqualified optics will be disabled, the link will be down and an error message will be written to the log file.  

The lpfc inbox driver  RHEL6.8 will display this message and the link will not come up. 

"3176 Misconfigured Physical Port - Port Name [wwpn] Unknown event status [status]"

The lpfc out of box driver rev 11.0.204.0 will display this message and the link will not come up.

"3176 Port Name [wwpn] Unqualified optics - Replace with Avago optics for Warranty and Technical support"

Suggestions for improvement: 
Use only Avago or Emulex certified SFP and QSFP optics.

Additional information: 
If any of the 3176 messages are seen the logs and the link does not come up you should contact Avago technical support.

Online Support
Create a case directly in the Technical Support database.

Response: (8:00 a.m. - 5:00 p.m. PST M-F) Hear from an engineer within two business hours and usually within minutes depending on work load.
Benefits: Create a case quickly and continue to work as we look for a solution. Receive an automated email with a new case number.
Email Support
Send an email to ecd-tech.support@avagotech.com:

Response: (8:00 a.m. - 5:00 p.m. PST M-F) Hear from an engineer within two business hours and usually within minutes depending on work load.
Benefits: Drop a quick email and continue to work as we look for a solution. Receive an automated email with a new case number.
Phone Support
US Toll Free: 1-800-854-7112
International: 1-714-885-3402
EMEA: +49 8941352 0244 (UK business hours only 8:30 am – 5:00 pm UTC M-F)
Comment 4 Rob Evers 2016-03-02 14:44:09 EST
The text above needs some editing and should be included in rhel6.8 beta release notes.  Tom Coughlan, please review:

Kernel Storage Drivers - Avago Emulex Fibrechannel driver - LPFC

LPE31000. LPE32000 HBAs and all variant HBAs of this architecture will:

Detect and enable both Avago or Emulex certified SFP and QSFP optics. 
For firmware rev 11.0.204.0 unqualified optics will be disabled, the link will be down and an error message will be written to the log file.  

The lpfc driver  in RHEL6.8-beta will display this message and the link will not come up. 

"3176 Misconfigured Physical Port - Port Name [wwpn] Unknown event status [status]"

Suggestions for improvement: 
Use only Avago or Emulex certified SFP and QSFP optics.

Additional information: 
If any of the 3176 messages are seen the logs and the link does not come up you should contact Avago technical support.

Send an email to ecd-tech.support@avagotech.com:

US Toll Free: 1-800-854-7112
International: 1-714-885-3402
EMEA: +49 8941352 0244 (UK business hours only 8:30 am – 5:00 pm UTC M-F)
Comment 5 Rob Evers 2016-03-02 14:46:49 EST
Laurie,

Please open another bugzilla and have someone provide a patch to fix the message to be appropriate ASAP.  Note that the fix should be derived from an upsteam posting.

Thanks, Rob
Comment 6 Tom Coughlan 2016-03-04 15:38:09 EST
(In reply to Rob Evers from comment #4)
> The text above needs some editing and should be included in rhel6.8 beta
> release notes.  Tom Coughlan, please review:
> 
> Kernel Storage Drivers - Avago Emulex Fibrechannel driver - LPFC
> 
> LPE31000. LPE32000 HBAs and all variant HBAs of this architecture will:
> 
> Detect and enable both Avago or Emulex certified SFP and QSFP optics. 
> For firmware rev 11.0.204.0 unqualified optics will be disabled, the link
                             ^--and later ?

> will be down and an error message will be written to the log file.  
> 
> The lpfc driver in RHEL6.8-beta will display this message and the link will
                             ^^^^--you may as well leave this off, since it
                                     will happen post-beat as well (even if the
                                     wording changes in the meantine.

> not come up. 
> 
> "3176 Misconfigured Physical Port - Port Name [wwpn] Unknown event status
> [status]"
> 
> Suggestions for improvement: 
> Use only Avago or Emulex certified SFP and QSFP optics.
> 
> Additional information: 
> If any of the 3176 messages are seen the logs and the link does not come up
                                      ^--in
> you should contact Avago technical support.
> 
> Send an email to ecd-tech.support@avagotech.com:
> 
> US Toll Free: 1-800-854-7112
> International: 1-714-885-3402
> EMEA: +49 8941352 0244 (UK business hours only 8:30 am – 5:00 pm UTC M-F)
Comment 7 Laurie Barry 2016-03-07 10:12:51 EST
Requested same from development.  I don't see this as a showstopper but we will clean it up.  We'll have to see if we can make this happen quickly enough for RH's cutoff which is like next week, right?
Comment 8 Laurie Barry 2016-04-04 13:27:44 EDT
I approve the changes Tom Coughlan has suggested for the release note.

The log output from the driver/firmware does not require any changes.
Comment 13 Rob Evers 2016-04-06 07:39:08 EDT
Fixed one minor grammar nit:

'and all HBAs variants'

should be

'and all HBA variants'

Note You need to log in before you can comment on or make changes to this bug.