Bug 1295503 - Packstack master branch is in the liberty repositories (was: Packstack installation fails with unsupported db backend)
Packstack master branch is in the liberty repositories (was: Packstack instal...
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
Liberty
Unspecified Unspecified
high Severity high
: ---
: trunk
Assigned To: Ivan Chavero
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 12:39 EST by David Moreau Simard
Modified: 2016-04-18 03:13 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-packstack-7.0.0-dev1685.g93ec9e5.el7.centos
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 18:59:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum repolist -v (2.96 KB, text/plain)
2016-01-04 12:40 EST, David Moreau Simard
no flags Details
/var/tmp/packstack/latest/manifests/172.19.2.51_cinder.pp (5.80 KB, text/plain)
2016-01-04 12:41 EST, David Moreau Simard
no flags Details
/var/tmp/packstack/latest/manifests/172.19.2.51_cinder.pp.log (466 bytes, text/plain)
2016-01-04 12:41 EST, David Moreau Simard
no flags Details
rpm -qa |egrep "openstack|packstack|puppet" (455 bytes, text/plain)
2016-01-04 12:43 EST, David Moreau Simard
no flags Details
grep pymysql /usr/lib/python2.7/site-packages/packstack/* -R (2.42 KB, text/plain)
2016-01-04 12:45 EST, David Moreau Simard
no flags Details

  None (edit)
Description David Moreau Simard 2016-01-04 12:39:32 EST
When doing packstack --allinone with current delorean, installation fails to complete with an error from Cinder:

Error: Unsupported backend configured at /var/tmp/packstack/876d62eca8e24d749905ee7a5f730f49/modules/cinder/manifests/db.pp:75 on node n51.crusty.ci.centos.org

When looking at the manifest, we notice that it tries to configure the mysql database with the following string:
database_connection => "mysql+pymysql://cinder:${cinder_rab_cfg_cinder_db_pw}@${cinder_rab_cfg_mariadb_host}/cinder",

This change is only for the Mitaka release. It should not be in liberty for both packstack and puppet modules.
Yet, when intalling Packstack from the current liberty repositories, we get a packstack package with the pymysql commit in it.

The pymysql support was added in the master branch of Packstack in https://github.com/openstack/packstack/commit/67b27906468ad845d045eb3c02a106a93e6e00eb.
This commit is not in the liberty branch of Packstack.
Comment 1 David Moreau Simard 2016-01-04 12:40 EST
Created attachment 1111545 [details]
yum repolist -v
Comment 2 David Moreau Simard 2016-01-04 12:41 EST
Created attachment 1111546 [details]
/var/tmp/packstack/latest/manifests/172.19.2.51_cinder.pp
Comment 3 David Moreau Simard 2016-01-04 12:41 EST
Created attachment 1111547 [details]
/var/tmp/packstack/latest/manifests/172.19.2.51_cinder.pp.log
Comment 4 David Moreau Simard 2016-01-04 12:43 EST
Created attachment 1111548 [details]
rpm -qa |egrep "openstack|packstack|puppet"
Comment 5 David Moreau Simard 2016-01-04 12:45 EST
Created attachment 1111549 [details]
grep pymysql /usr/lib/python2.7/site-packages/packstack/* -R
Comment 6 David Moreau Simard 2016-01-04 13:37:35 EST
It turns out that up until now, we have been testing and releasing the upstream master branch of packstack in the liberty delorean repositories.

This is because delorean fails to pickup the "liberty" branch (https://github.com/openstack/packstack/tree/liberty) and instead expects a branch called "stable/liberty" and falls back to the master branch.
Comment 7 Alan Pevec 2016-01-05 01:25:04 EST
I've pushed stable/liberty to openstack/packstack git repo.
Comment 8 Alan Pevec 2016-01-05 10:59:21 EST
When merged https://review.openstack.org/263782 should trigger new Delorean Liberty build.

Note You need to log in before you can comment on or make changes to this bug.