Bug 1295504 - S29CTDBsetup hook script contains outdated documentation comments
S29CTDBsetup hook script contains outdated documentation comments
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: gluster-smb (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 12:49 EST by Michael Adam
Modified: 2016-06-16 09:53 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:53:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Adam 2016-01-04 12:49:33 EST
Description of problem:

The S29CTDBsetup hook script contains outdated documentation comments


How reproducible:

Look at the S29CTDBSetup.sh hook script.


Actual results:

One finds the comment "Adds the necessary configuration changes for ctdb in smb.conf and restarts smb service."


Expected results:

This comment should not exist, since the functionality has been removed.
Comment 1 Vijay Bellur 2016-01-04 12:52:25 EST
REVIEW: http://review.gluster.org/13168 (hook-scripts: remove outdated comment from C29CTDB start scipt) posted (#1) for review on master by Michael Adam (obnox@samba.org)
Comment 2 Vijay Bellur 2016-01-10 05:52:58 EST
COMMIT: http://review.gluster.org/13168 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 1cdea236601ebe872d432ff9ee63833dfac0d5cb
Author: Michael Adam <obnox@samba.org>
Date:   Mon Jan 4 16:45:19 2016 +0100

    hook-scripts: remove outdated comment from C29CTDB start scipt
    
    This script does not change Samba's config any more.
    
    Change-Id: Ie6001f9a49006f95b291e24252dc362f2a7db14c
    BUG: 1295504
    Signed-off-by: Michael Adam <obnox@samba.org>
    Reviewed-on: http://review.gluster.org/13168
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anoop C S <anoopcs@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 3 Mike McCune 2016-03-28 18:22:31 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Niels de Vos 2016-06-16 09:53:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.