Bug 1295520 - Manual mount command in S29CTDBsetup script lacks options (_netdev ...)
Manual mount command in S29CTDBsetup script lacks options (_netdev ...)
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: gluster-smb (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
Michael Adam
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 13:20 EST by Michael Adam
Modified: 2016-06-16 09:53 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:53:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Adam 2016-01-04 13:20:56 EST
Description of problem:

The manual mount command in the S29CTDBSetup.sh start script does not yield the same result as the created fstab entry. Specifically, the options _netdev,defaults,transport=tcp are missing.


Expected results:

The effects should be the same.
Comment 1 Vijay Bellur 2016-01-04 13:22:35 EST
REVIEW: http://review.gluster.org/13170 (hook-scripts: reconsile mount, fixing manual mount) posted (#1) for review on master by Michael Adam (obnox@samba.org)
Comment 2 Vijay Bellur 2016-01-11 05:58:23 EST
REVIEW: http://review.gluster.org/13170 (hook-scripts: clean up and fix mount commands and options) posted (#2) for review on master by Michael Adam (obnox@samba.org)
Comment 3 Vijay Bellur 2016-01-11 06:03:53 EST
REVIEW: http://review.gluster.org/13170 (hook-scripts: S29CTDBsetup: clean and fix mount commands and options) posted (#3) for review on master by Michael Adam (obnox@samba.org)
Comment 4 Vijay Bellur 2016-01-15 08:53:05 EST
COMMIT: http://review.gluster.org/13170 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit a0e690fbdf5681c7cf644271de5cc03bde3fef8f
Author: Michael Adam <obnox@samba.org>
Date:   Mon Jan 4 18:50:38 2016 +0100

    hook-scripts: S29CTDBsetup: clean and fix mount commands and options
    
    This refactors the mount options of S29CTDBstart.sh into one
    variable, removing the superfluous mentioning of 'default'.
    The manual mount command is fixed to:
    - also use the common options, thereby adding
      _netdev,transport=tcp
      (while this does not have an effect for the _netdev
       option, it makes a difference for the transport option),
    - also use the HOSTNAME variable just like the fstab entry,
    - use a "/" in the remote location specification.
    Hence it now behaves identically to the fstab mount.
    
    Change-Id: Ibb7613b1b1278ab13745846baa79268db226ef19
    BUG: 1295520
    Signed-off-by: Michael Adam <obnox@samba.org>
    Reviewed-on: http://review.gluster.org/13170
    Tested-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 5 Mike McCune 2016-03-28 18:23:05 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Niels de Vos 2016-06-16 09:53:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.