Bug 1295532 - channel mappings missing for RHEL 7 and 7 EUS channels
channel mappings missing for RHEL 7 and 7 EUS channels
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
2.4
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Grant Gainey
Red Hat Satellite QA List
:
Depends On: 1282474
Blocks: space27
  Show dependency treegraph
 
Reported: 2016-01-04 13:48 EST by Grant Gainey
Modified: 2017-09-28 14:11 EDT (History)
7 users (show)

See Also:
Fixed In Version: spacewalk-java-2.5.31-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1282474
Environment:
Last Closed: 2016-06-16 03:54:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grant Gainey 2016-01-04 13:48:47 EST
+++ This bug was initially created as a clone of Bug #1282474 +++

Description of problem:
1) When you have a system registered to 7.1 EUS that base channel is not shown as available on the update software page in Satellite 5.x
2) When you have a system on the RHEL 7 server channel it does not show 7.1 EUS as a possible base channel to change the system to.
3) When you change a system from 7.1 EUS base channel to 7 Server the Red Hat provided child channels do NOT follow.  As an example if the system is on 7.1 EUS with the optional channel and you change the base channel to 7 Server the optional channel is no longer subscribed to.  This happens with other child channels as well.

It seems that channel mappings for RHEL 7 channels are missing.

Version-Release number of selected component (if applicable):


How reproducible:
- Always


Steps to Reproduce:

[1]:
1. Sync RHEL 7 and RHEL 7.1 EUS channel on Satellite server.
2. Register a test RHEL 7 system to Satellite server.
3. Now try to alter base channel from RHEL 7 to RHEL 7.1 EUS
4  RHEL 7.1 EUS channel is not available.


[2] :
1. Sync RHEL 7 and RHEL 7.1 EUS channel on Satellite server.
2. Register a test RHEL 7 system to Satellite server to have (*) Limited Updates Only.
3. Now try to alter base channel from RHEL 7.1 EUS to RHEL 7
4  RHEL 7 channel is not available.


Actual results:

1) When you have a system registered to 7.1 EUS that base channel is not shown as available on the update software page in Satellite 5.x
2) When you have a system on the RHEL 7 server channel it does not show 7.1 EUS as a possible base channel to change the system to.
3) When you change a system from 7.1 EUS base channel to 7 Server the Red Hat provided child channels do NOT follow.  As an example if the system is on 7.1 EUS with the optional channel and you change the base channel to 7 Server the optional channel is no longer subscribed to.  This happens with other child channels as well.
 
Expected results:

- When you have a system registered to 7.1 EUS that base channel should shown as available on the update software page in Satellite 5.x
- When you have a system on the RHEL 7 server channel it should show 7.1 EUS as a possible base channel to change the systems base channel.
- When you change a system from 7.1 EUS base channel to 7 Server the Red Hat provided child channels should follow.  


Additional info:

We can alter base channel from RHEL 7.1 EUS to RHEL 7 OR RHEL 7 to RHEL 7.1 EUS using spacewalk-api "system.setBaseChannel".

For eg :
spacewalk-api --server=dhcpx-x.abcde.fgh.redhat.com --user admin --password=123456 system.setBaseChannel "%session%" 1000010001  rhel-x86_64-server-7.1.eus

--- Additional comment from Jan Hutař on 2015-11-18 04:38:47 EST ---

Hello,
mine setup is:

  On the client: redhat-release-server-7.1-1.el7.x86_64
  On the satellite: satellite-schema-5.7.0.20-1.el6sat.noarch
                    spacewalk-java-2.3.8-120.el6sat.noarch
  Synced (among others): rhel-x86_64-server-7
                         rhel-x86_64-server-7.1.eus

I can confirm scenario [1]:

  1. Register client into rhel-x86_64-server-7
  2. In webUI Systems -> Systems -> Recently Registered -> <system> ->
              -> Software -> Software Channels
  3. In "Base Software Channel" I can *not* see "RHEL EUS Server
     (v. 7 for 64-bit x86_64)"
  4. I can not see EUS channel even later after I switch base channel to
     "(none, disable service)"

I can *not* confirm scenario [2]:

  1. Register client into rhel-x86_64-server-7.1.eus
  2. In webUI Systems -> Systems -> Recently Registered -> <system> ->
              -> Software -> Software Channels
  3. In "Base Software Channel" I can see "Red Hat Enterprise Linux Server
     (v. 7 for 64-bit x86_64)" and can change to it

To register to EUS channel, I have used either activation key with the channel specified, or `rhn_register` where I have selected "(*) Limited Updates Only".

--- Additional comment from Tomas Lestach on 2015-12-14 09:17:51 EST ---

Channel-metadata has been fixed. However, it looks we need to do some code changes to get it working due to the new approach in RHEL7

Looks like the main problem is, we're getting:
rhelVersion = 7.0 instead of 7Server at:

https://github.com/spacewalkproject/spacewalk/blob/master/java/code/src/com/redhat/rhn/manager/channel/ChannelManager.java#L1670

--- Additional comment from Tomas Lestach on 2015-12-15 08:42:12 EST ---

More hints:

* we cannot use the version any more ...
# rpm -q --qf="%{name} %{version} %{release}\n" redhat-release-server
redhat-release-server 7.2 9.el7
in comparison with RHEL6:
# rpm -q --qf="%{name} %{version} %{release}\n" redhat-release-server
redhat-release-server 6Server 6.7.0.3.el6

* looks like we could use a provides here:
# rpm -q --provides redhat-release-server | grep 7Server
system-release(releasever) = 7Server
(of course for server ... analogously for workstation, ...)

--- Additional comment from Akshay Mankumbare on 2015-12-18 00:11:00 EST ---

Hello,

Both 7.1 EUS and 7.2 EUS channels allow you to move to RHHEL 7 channel now.

But you still do not have the option to move from :
- 7.1 EUS to 7.2 EUS
- 7.2 EUS to 7.1 EUS
- from RHEL 7 base to 7.2 EUS or to 7.1 EUS
Comment 1 Grant Gainey 2016-01-04 14:39:51 EST
spacewalk.github: 
ead679922dd74227e2018cc03121da3ce06f0b22 
07b4580d48068e564d33f59f1a222fd16378cce5
Comment 2 Tomáš Kašpárek 2016-06-16 03:54:05 EDT
Spacewalk 2.5 was released.
Comment 3 Eric Herget 2017-09-28 14:11:00 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.