Bug 1295540 - Cannot start a build referring directly to git repository
Cannot start a build referring directly to git repository
Status: CLOSED CURRENTRELEASE
Product: Copr
Classification: Community
Component: frontend (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: clime
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 14:21 EST by Jan Pokorný
Modified: 2016-02-04 03:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-04 03:58:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that might solve denormalized/broken build links (1.45 KB, patch)
2016-01-07 14:46 EST, Jan Pokorný
no flags Details | Diff

  None (edit)
Description Jan Pokorný 2016-01-04 14:21:23 EST
There seems to be an issue in the form validation step.

At http://copr.fedoraproject.org/coprs/jpokorny/booth/new_build_mock/
- SCM Type: Git
- SCM URL: https://github.com/ClusterLabs/booth.git
- Spec File: booth.spec
- Git Branch: (either empty or "master")
- various permutations of the checkboxes at the bottom

-> Build -> "This field is required." message above the form


Got the same result with "Git and Tito" way.
Tried also with jpokorny/clufter + https://pagure.io/clufter.git
+ misc/clufter.spec combo but no cigar.
Comment 1 Link Dupont 2016-01-06 00:33:19 EST
I was getting this error yesterday as well. Today, I can submit a build using Mock SCM, but the build immediately fails with "Unknown error". SRPM Upload succeeds.
Comment 2 Jan Pokorný 2016-01-07 14:46 EST
Created attachment 1112606 [details]
Patch that might solve denormalized/broken build links

re [comment 1]:

Confirming, the web form validation issue looks solved now.

The current results I can observe with booth per above setup:

Source Type: Mock build from a SCM repository 
-> Build State: failed
-> State Description: Unknown error.
(e.g., https://copr.fedoraproject.org/coprs/jpokorny/booth/build/152110/)

Source Type: Tito build from a Git repository
-> Build State: failed
-> State Description: Attempt to build SRPM have failed.
(e.g., https://copr.fedoraproject.org/coprs/jpokorny/booth/build/152111/)

Apparently, user is helpless here as no proper logs are provided.
-> sub-RFE: please provide better diagnostics for these dynamic
   types of importing a package to be built


Beside that, there is an issue with rendering
"/<username>/<coprname>/builds/" template wrt. build id links:

>       <tr class="build-row" >
>         <td data-order="152111">
>           <a href="
>   
>     /coprs/jpokorny/booth/build/152111/
>   
> ">
>             152111
>           </a>
>         </td>
>         <td>

Which might be solved with the attached patch (UNTESTED).
Comment 3 clime 2016-01-16 14:08:47 EST
"Git & Tito" seems to work on copr-fe-dev.cloud.fedoraproject.org right now (srpms are successfully imported and builds run).
Comment 4 clime 2016-01-21 08:13:57 EST
Currently "Git and Tito" should work on the production instance. The main problem was missing dependency.

Apart from that, I agree that better diagnostic output is needed.
Comment 5 Robert Scheck 2016-01-21 17:14:19 EST
"Mock SCM" seems to be broken further on.
Comment 6 clime 2016-01-23 11:44:07 EST
Should be fixed now (bad user config on the server, probly some change in .spec file will be needed, I'll look into it). Thanks for the report.

These two features are still experimental so you might expect some problems. We will improve it in very near future.
Comment 7 clime 2016-01-25 09:53:03 EST
Better diagnostics and error handling provided by 4e2245f554
Comment 8 clime 2016-01-25 11:24:11 EST
The problem with leading/trailing whitespaces in the generated links is now (partially) solved by 13cd5e7bc3
Comment 9 Jan Pokorný 2016-01-29 08:12:45 EST
Note that Mock SCM builds fail in staging instance
(1.80-1.git.85.0b772db.fc23) where they work OK
in the production (1.79-1.fc23).
Comment 10 Miroslav Suchý 2016-02-03 07:28:41 EST
Code with this fix is currently deployed on copr-fe-dev.cloud.fedoraproject.org. You can test it there before it will be deployed to production.
Comment 11 Miroslav Suchý 2016-02-04 03:58:13 EST
This fix has been just deployed to production.

Note You need to log in before you can comment on or make changes to this bug.