Bug 1295569 - overcloud stack create fails but 'openstack overcloud deploy' exits with status 0
overcloud stack create fails but 'openstack overcloud deploy' exits with stat...
Status: CLOSED DUPLICATE of bug 1370527
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: Julie Pichon
Ola Pavlenko
: Automation, AutomationBlocker, Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 16:46 EST by Steve Linabery
Modified: 2017-05-30 21:13 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-17 07:54:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from openstack overcloud deploy (58.47 KB, text/plain)
2016-01-04 16:46 EST, Steve Linabery
no flags Details

  None (edit)
Description Steve Linabery 2016-01-04 16:46:16 EST
Created attachment 1111567 [details]
output from openstack overcloud deploy

Description of problem:
In a virthost-based OSP8 poodle CI run, I am seeing 'openstack overcloud deploy' exit 0 even though the stack is not created. Overcloud deployment log attached.
Comment 3 Mike Burns 2016-04-07 17:03:37 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 6 Jason E. Rist 2016-10-14 18:25:44 EDT
Is this still an issue?
Comment 7 Julie Pichon 2017-02-17 07:54:49 EST
I will mark this as a duplicate of bug 1370527 as the other bug is seeing more activity. If you disagree with this or the resolution though, please feel free to reopen or open a new one.

Also, if you have a set of templates and/or steps that clearly help to reproduce the failure case with the wrong exit code, that would be tremendously helpful. I suspect there might be different failure paths with this problem.

*** This bug has been marked as a duplicate of bug 1370527 ***

Note You need to log in before you can comment on or make changes to this bug.