Bug 1295585 - [abrt] system-config-language: language_backend.py:128:write_locale_conf:FileNotFoundError: [Errno 2] Adresář nebo soubor neexistuje: '/etc/vconsole.conf'
[abrt] system-config-language: language_backend.py:128:write_locale_conf:File...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:5925db795612ee18b5004633094...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 18:27 EST by Andrej Podzimek
Modified: 2016-03-31 01:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 01:01:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (773 bytes, text/plain)
2016-01-04 18:27 EST, Andrej Podzimek
no flags Details
File: environ (191 bytes, text/plain)
2016-01-04 18:27 EST, Andrej Podzimek
no flags Details

  None (edit)
Description Andrej Podzimek 2016-01-04 18:27:27 EST
Version-Release number of selected component:
system-config-language-3.3.0-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 /usr/share/system-config-language/system-config-language.py
executable:     /usr/share/system-config-language/system-config-language.py
kernel:         4.2.8-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
language_backend.py:128:write_locale_conf:FileNotFoundError: [Errno 2] Adresář nebo soubor neexistuje: '/etc/vconsole.conf'

Traceback (most recent call last):
  File "/usr/share/system-config-language/language_gui.py", line 323, in ok_btn
    sysfont, sysfontacm)
  File "/usr/share/system-config-language/language_backend.py", line 128, in write_locale_conf
    fd = open(vsconsole_file, "r")
FileNotFoundError: [Errno 2] Adresář nebo soubor neexistuje: '/etc/vconsole.conf'

Local variables in innermost frame:
sysfontacm: 'utf8'
self: <language_backend.LanguageBackend object at 0x7f333d312518>
old_path: '/etc/sysconfig/i18n'
sysfont: 'latarcyrheb-sun16'
modules: ''
default_lang: 'cs_CZ.UTF-8'
vsconsole_file: '/etc/vconsole.conf'
locale_path: '/etc/locale.conf'
Comment 1 Andrej Podzimek 2016-01-04 18:27:32 EST
Created attachment 1111583 [details]
File: backtrace
Comment 2 Andrej Podzimek 2016-01-04 18:27:33 EST
Created attachment 1111584 [details]
File: environ
Comment 3 Parag Nemade 2016-01-05 03:26:02 EST
This is really strange. See
$ rpm -qf /etc/vconsole.conf
systemd-222-10.fc23.x86_64

Howcome you don't have systemd package installed on your system? Or you manually removed /etc/vconsole.conf file?
Comment 4 Andrej Podzimek 2016-01-18 10:36:06 EST
I do have the package installed. I haven't removed vconsole.conf manually. Reinstalling systemd doesn't restore that file. So something is broken here, in a deep and subtle way. I recreated vconsole.conf manually by simply using the file format from Arch and setting the font and encoding options to the same values I already have in /etc/default/grub. That seems to work fine.
Comment 5 Parag Nemade 2016-01-18 11:01:02 EST
if reinstalling systemd is still not giving you vconsole.conf then something is broken on your system. This does not look like a issue of system-config-language package as required file is not available. Looks like this is NOTABUG for system-config-language.

Note You need to log in before you can comment on or make changes to this bug.