Bug 1295612 - journal corruption, most all kernel messages for current day are missing
journal corruption, most all kernel messages for current day are missing
Status: CLOSED DUPLICATE of bug 1294002
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 21:34 EST by Chris Murphy
Modified: 2016-08-10 11:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-10 11:44:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journal file --verify says is corrupt (4.27 MB, application/x-tar)
2016-01-04 21:36 EST, Chris Murphy
no flags Details
journal others (731.18 KB, application/x-tar)
2016-01-04 21:38 EST, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2016-01-04 21:34:32 EST
Description of problem:

Short: Journal lacks roughly 12 hours of kernel messages in an otherwise readable journal log.


Long: Soon after a 'dnf install kernel' dmesg reports corruption in systemd journal file and that system.journal is being replaced by a new one. journalctl --verify shows no problems; btrfs can read all files (to /dev/null) without triggering any fs checksum mismatch errors.

Upon reboot, journalctl --verify lists journal corruption; still btrfs reads files to /dev/null no errors. But then I also can't find the corruption message I saw with 'dmesg | grep -i corrupt' in the previous boot. And then I see 'journal -k -b -1' shows no kernel messages for almost 12 hours, except some audit messages. For sure there were a bunch of kernel messages today, but none of them are locateable in the journal.

Could be related to bug 1294002 (same system) but manifests differently

Version-Release number of selected component (if applicable):
systemd-222-10.fc23.x86_64

How reproducible:
unknown, some form of journal corruption is inevitable but I don't know what triggers it and manifestation of corruption is different each time; this is the first time I've noticed specifically kernel messages missing.

Steps to Reproduce:
1. Uncertain
2.
3.

Actual results:

Kernel messages in previous boot appear to be missing.


Expected results:

Kernel messages for prior boot should be preserved more reliably.


Additional info:
Comment 1 Chris Murphy 2016-01-04 21:36 EST
Created attachment 1111647 [details]
journal file --verify says is corrupt
Comment 2 Chris Murphy 2016-01-04 21:38 EST
Created attachment 1111648 [details]
journal others

These are not marked as corrupt by --verify, but go with the other log file, so this is included just to have a complete submission.
Comment 3 Chris Murphy 2016-08-10 11:44:31 EDT
Ultimately this is the same problem as bug 1294002.

*** This bug has been marked as a duplicate of bug 1294002 ***

Note You need to log in before you can comment on or make changes to this bug.